"Ascension mod" or: "Winning DDA: the mod"

mod

#123

You know, I should really start testing these new versions before I release them.
There’s certainly a bug with the new mastermind lair addition to the hell castle I’ll have to look into, really simple stuff.
In other news, DOOM labs and hell castles finally spawn more reliably.

Mmmmh, yes. Yes. Now they spawn correctly.
Apparently with the new unfucking of the radial PK overmaps, overriding is no longer needed. Literally a one line change, yet again I’ll have to push a new release for it.

Annnd pushed. Get your garamond atlas fix.


#124

Well, I was thinking of migrating worlds soon anyway. I have a lot of overmaps already spawned…


#125

–I imagine you could use the debug stuff to help with testing a lot, it’d make sense to me. But seriously, you don’t test things in the first place? That seems ‘kinda’ derpy, but your mod is awesome and I’m not gonna complain. Just seems a little odd to me. Or Ood if we are talking in Doctor Who alien terms.
–Remember kids, no Ood or drink allowed in the library!
–I have a tendency to restart a lot of the time anyway, because reasons. So it does not frustrate me too much.


#126

–Err, I recently found a giant royal bee (I think it was) that I presume was from this mod. Seeing as it was single ‘handedly’ able to take down a small horde of zombies and seems to shook electricity I can reasonably assume I should avoid it with my rookie alchemist, right?
–Roland III walked into a nearby village and found two things, a massive horde of zombies, and that bug. I watched the fight from afar and I was just like, “Hmm, maybe not.” Luckily a stupidly courageous pig lured it away so that I was able to pulp and butcher the zombie horde! I shall honor it’s noble sacrifice, and give it an honorable grave once the bee leaves.
–Of course, I can’t actually do that, but I’m just going to pretend I did by digging a shallow hole and dropping the corpse in it.
–Luckily, while the bee would wreck me if it came to spotted me, it actually acts almost like a guard, patrolling the northern and eastern border of the village. It also helps me gather food by brutally slaying soldiers of the Great Raccoon Army that constantly tries to invade from the forest.
–Seriously, there always appears to be a bunch of hostile raccoons attacking anything and everything not of their kind.


#127

1

here’s my blob mobile

slimy solar array, it doesn’t work. no charging at all.
did i do something wrong?
even if i remove all those roofs, it doesn’t charge any batteries.


#128

Wait, what? You can have blob car? Where and how do you get that? Me likey!


#129

oozing receptacle: 25 liters?
Should be 250, too. And the solar array should give a car battery’s worth of estorage to boot. Something’s fishy.
Latest version?
I was also toying with heavily nerfing slimy solar to regular solar panel levels levels but that’s not really worth a new version. In the end it just means you gotta put more of them.

Quick check: All blazemod’s blob-related files haven’t been altered in 2 months after the complete blobcar rework.

That’s worse, the problem might be upstream then.
Let me know.


#130

Can we have a guide to the new Blobcar parts, please? Preferably in a separate thread so we can ask our questions there.


#131

I don’t know how important this is, but I found some debug messages that popped up seemingly for this mod. Here they are:
–>recipe dobelisk defines invalid result
–>dobelisk in inline_construction_178 is not a valid item template
–>vehicle part biter has unknown or incorrectly specified repair requirements blazemod_blobfix
–>vehicle part oozle_nom uses undefined item oozle_pod
–>missing item definition: oozle_pod
–>vehicle part sick has the TURRET flag, but is not made a gun itme
–>both into and into_group defined for monster mon_ant

The game is currently playable just fine so far, but it seemed like it might be important to note this.
Side thing, does this mod add some sort of ‘radiation’ effect to food? Or at least meat anyway? In the description of some dog meat it says: [4/10 rad]
I have no clue what that means.


#132

PK’s Rebalancing adds radiation to a lot of things. The idea is that there’s radiation everywhere because of all the bombs that where dropped at the beginning of the Cataclysm.


#133

latest, clean reinstall, use Ascension mods only, nothing works
Maybe split the blob E-storage/Solar array might work?

the receptacle is works fine, that 25.0 is showing how much it contain right now, i guess.


#134

Bloody hell, what did they even merge this time for that to happen.
Alright, I’ll look into it


#135

Some water vessels can impart rads, check descriptions.


#136

While trying to look into the blobcar bug (latest experimental, latest version of ascension, nothing else), I didn’t get those bugs at worldgen.

@Moreal

Tried latest experimental, latest version of ascension, nothing else. Slimy solar array installs fine, has charges, but does not charge the battery.

EDIT:
Found the problem. Fixed the problem.

Also made the slimy solar array a “slimy sparkler”, heavily nerfed (200 instead of 2000, still twice than an upgraded solar panel) the output and removed the need for a welder to install it. Also heavily nerfed the durability form 7 MILLION to 37 K, as I had already done in my local version. Let’s be reasonable here.

Sadly, this means I’ll have to throw in yet another release. Gods above, this is annoying.

Release done. Yet again, get your fix.


#137

It works like charm now!
My thanks, brother.


#138

I forget, will I need to make a new world to get the latest version of your mod? Or would I simply replace the mods in the world’s folder to fix it? Because I assume it would be the world itself, seeing as that’s where the problem currently lies. :face_with_raised_eyebrow:
The Alchemist (Literally my character’s name) isn’t very far, but I’d miss the free food (also known as the Great Raccoon Army) that is being farmed by the Giant Royal Bee. Side mention, apparently a little down from the village I reside in there is another Giant Royal Bee guarding nearby the southern edge. Already, it has electrocuted a mini horde of zombies that had tried to invade. :grin:


#139

This mod has a patch that makes it compatible with PK’s Rebalance. Anyone know how to make it compatible with PK’s Rebalance Ascension?

I must have more mutant power!


#140

Just a side thing to mention, I find it strangely easy to find mobile meth labs… Is that normal? There always appears to be one relatively nearby spawn, however it is (of course) very useful in crafting various things. I intend to one day turn one of them into the mighty Methenger of Death! If you don’t understand the play on words, it is a mixture of messenger and meth.


#141

Mobile Meth Labs are vanilla spawns. And considering the type of world that there was Pre-Cataclysm, it’s no small wonder that you keep finding them.

Those Chemistry sets rock, though.


#142

For this last realease? No. Really minor stuff, no mapgen changes, I can assure save compatibility.