"Ascension mod" or: "Winning DDA: the mod"

mod

#83

Fixed a bug from the recent slimepit change where the slime pits just wouldn’t spawn in some cases.
Also added a really good reward for them other than the usual death drop and added several strong monsters that will barrel towards you horrifyingly, to balance it out.


#84

I need a rapid “Leave-No-Survivors” method to kill a crap ton of ants that made their home near my base. Without me realizing it, it got to a point where it’s far out of my control.

Is it possible for me to use the available weapons to destroy them all (getting them to converge in a single area would be quintessential, but I can’t seem to get them all to aggro at me all at once), and most of what I tried leaves enough Young Queen Ants alive to keep reproducing?

Can anyone help?


#85

Turreted laser cannon with a good power supply is always a strong option.
Firing one of those missile silos at the hive should wipe out anything on that particular square, and the radiation and rubble should kill anything new that spawns (Can ants die from radiation?)
Fire might work, especially the Rivtech flamethrower.
Mininuke?
Horde of NPCs with heavy survivor armor and awl pikes?
There is the sprayable toxic gas, but I don’t know how efficient that would be. Might be worth a try.


#86

It’s not a hive: It’s Young Queen Ants who multiplied exponentially (from PK’s mod).

A missile silo will not hit them all (and I can’t access one). A mininuke might work if I do dozens of them.
Never tried toxic gas. Currently I’ve been using the BFG, which is an enhanced Chain Lightning. But so far nothing’s really worked because they start to run away after I kill enough.

NPCs will not work. Young Queen Ants have a flamethrower attack.

Hmm… either I just debug kill all monsters, try more BFG shells, summon a shoggoth from Arcana to help, or perhaps just hope the makers of this modpack can fiddle with the code to make all the ants aggro you if you kill one (don’t know why this doesn’t happen; I’m pretty sure its supposed to).

EDIT: Gonna see if I can get them to aggro the laser turret like they would with a regular turret.


#87

That does sound like a pain in the ass. NPCs might work if you give them the fireproof survivor armor. Get enough and they should all chase them down and murderise them.


#88

Well, at least I know what it must have been like to fight in the Great Emu War.

…Speaking of which, I can only imagine how awful the Cataclysm is in Australia. Everything there is already trying to kill you…


#89

I think everything would just kind of cancel out really. The giant spiders would poison the nether beasties, the giant snakes would eat all the zombies, the Goo would just melt and be pathetic… Fun on a bun really.


#90

Gasp You have a donkey? How did you get one? I wanna donkey!


#91

Well, I have a CVD machine, but I can’t craft a Diamond Matrix with it.

Help?


#92

Let’s see now…
You got the spiral stone and the scalpel?


#93

Scapel? It says I need a chisel and a tool with Hammering 3! (Which I do have)


#94

Yeah, chisel, my bad.
So you got all the stuff but it still won’t work?
I’m gonna debug that one a sec.

EDIT:
Aaaaaaand okay that was a lot of work actually but I managed to make it work.
Turns out the real problem was that the game can’t handle pseudo_items on terrain, so the only way is to sacrifice the machine now!
I like it.
Changed the requirements, made CVD machine control panel disassemblable.
Have a pic.

Aaaand it works. Updated.


#95

Better coat my Nodachi then. I’ve been a bit lazy…

EDIT: How the fuck did you get your Fabrication that high? I’ve been struggling to get most of my skills past 11 or 12!


#96

I downloaded the latest build of DDA and the latest version of the mod and now I’m getting an error on character creation.

It says “both into and into_group defined for monster mon_zombie_tough”. It isn’t an actual problem; the game seems to play fine in spite of it, but I didn’t know if you were aware of it.

I’m fairly sure it’s coming from PK’s Rebalance.


#97

It’s wizmode.
Also, I forgot to add the dummy item to the repo, I just added the deconstruction recipe. Woops.

@mentos046
Oh boy. I’ll look into that one too.

EDIT:

Removed redundant override in zombie_tough. Monster spawns as normal, no debug message appears. Fixed.

Added dummy cvd_core item. Fixed.


#98

Hate to bother you again so soon, but I seem to be getting the same problem for monster_mon_ant and monster_mon_ant_larvae now. I can’t be sure it’s coming from this mod, but the last one was so I thought I’d inform you.


#99

Not at all, thanks for the report! I can see this becoming an even bigger problem soon.
I’ll look into what’s causing it.

EDIT:

Removing the offending strings seems to fix the problem, but I haven’t managed to find a naturally occurring anthill by generating several overmaps. This worries me.
Looks like it’s https://github.com/CleverRaven/Cataclysm-DDA/pull/23012 's fault.
There’s also a bug report on the github: https://github.com/CleverRaven/Cataclysm-DDA/issues/23034


#100

Finally managed to deal with the problem.

Anthills now spawn safely without any bugs.

Now you don’t have an excuse anymore, go get those eggs!


#101

Did you do anything to mosquitoes? I got “injected with poison” by one a couple of times and my pain just went higher and higher until I died.

Edit: Death possibly not due to pain? I debugged my pain back to zero and still died. No idea from what. Seems to have something to do with the steadily increasing painkiller level, but I don’t know how to fix it.


#102

Thank you for your question, I’ve been meaning to give a blanket answer to cover all the related questions I’ve been seeing in the thread.

Short answer: No.

I haven’t done anything that PK doesn’t do by default, except fix some of the mess.
For the sake of clarity, I’ll tell you and everyone else interested what I’ve done, other than unifying the mods and fixing them up to make them work smoothly together:

Added Spider Mastermind’s Lair
Winning constructions, recipes and drops
New slime pit
Removed acid rain (PK)
Blobcar rework
Fixed the mess that happened with new terrain and PK clashing together
Syntax fixes (PK)
Grammar fixes (PK)
Removal of hardcoded vitamin effects (PK)
A bunch of other stuff I don’t remember but were fairly minor like removing the cyborg’s hypervitaminosis attack

That’s basically the long and short of what I’ve done. I haven’t altered monsters in any way, anything you see is just PK.

Actually, speaking of redundant and annoying mechanics I’m thinking of removing wound inflammation since it looks like the only way of treating it is royal jelly and it’s just frequent pain in the ass to deal with. Maybe I’ll just edit it to actually do something interesting but most likely I’ll just remove it.
I’m also thinking of removing blob-dropping-on-death zombies because of just how much they slow down the game with the wild multiplying function. Seriously, there’s a reason we’ve dropped dynamic spawn.

As for the mosquito (I assume you mean the giant mosquito), yeah, he has a nasty sickness attack, think dermatik on steroids. Want an advice? Just stay away from swamps if you’re not in winter or can reliably kill stuff from afar.