"Ascension mod" or: "Winning DDA: the mod"

mod

#264

Can’t reproduce with this morning’s experimental.


#265

Active world mods (Default only + Acsension):
image

Game version (latest from this morning):
image

Starting trait: Far-sighted

Items worn (default):
image

Attempting to read anything:
image

Also, when I load a new world without the Acsension mod in latest experimentals, it allows me to read with reading glasses, which leads me to believe it’s a strange bug with the mod.

PK’s Rebalance works by itself (with patch by dissociativity) along with many other location based mods.


#266

Aw jeez come on I just updated the thing

I’ll have to comb through the last pulls or something

EDIT:

Okay I have literally no idea why this is happening, ascension by itself only adds some junk to the other mods, maybe it’s Arcana?
(It’s not Arcana)
Maybe it’s PK’s ascension? But I mean, I just straight up copypasted the fork, it couldn’t be.

Aaand it’s PK ascension. I get the error with PK:A and dark days ahead alone
Fuck. Don’t ask me how. I’ll look into it I guess? Repaste the folder?


#267

System: Windows 7 64-bit.
Version tested:
http://dev.narc.ro/cataclysm/jenkins-latest/Windows/Tiles/cataclysmdda-0.C-7696.zip

I’ve narrowed it down for you. My character is able to read with reading glasses when I load Ascension, then disable PK Rebalance: Ascension mod. So it works with Arcana and Vehicle Additions, but not with PK Rebalance.


#268

Fixed it!
It’s either the pk mutation override or the pk armor override, just gotta delete the glasses or the mutation. I tried with both and now I’ll look which is the bad one
Edit: it was the armor, as I suspected. The game didn’t recognize the overridden glasses (oh man do we even use override anymore)
easy fix, I’ll pull it in a minute


#269

Awesome. I’ll try the mod tonight after work, the changes look really cool.


#270

Thanks! I just ended up trashing the armor override and I checked quickly on the fork and turns out I also needed to update some of the muts too so an update was due I guess


#271

It’s working now, that’s really cool. I was even able to load it into an older save with the most recent experimental. I guess I’ll have to travel a fair ways to start to see magical stuff (never played Arcana mod before)


#272

There’s a special spot in arcana, the strange grove, that is guaranteed to always have a strange map, which marks all the different arcana structures in the whole mapblock. Pretty useful. The whole place is well guarded, so sometimes is better to just run in and out.


#274

Capital work my dude thanks for the update! Just a little nitpick, a couple of weeks ago there was a change in how monster spawning works for DDA mods, With this update its an annoying change that has to be made once to all spawnlists that add or change mobs AKA PKs and/or arcana, I already made the necessary changes to my personal files so if you need help with I could gladly send it to you, also you are missing the skeleton juggernot spawn in Pks, also the flamethrower zombie I think? Still for taking care a little modpack I salute thee!

Edit: Another thing, after trying out the new version I realized something, the mutagen file on the items folder doesnt have a .json attached to it, it crashed my game since I had an older version installed when I updated, you should change that little mistake


#275

Thanks for the tip, if you can post the fixes every little bit helps!
For mutagen.txt, I think that’s an obsoleted old file there for archival purposes, if you’re playing a pre-mutagen change everything’s gonna crash like it used to do before the mutagen change (hence why it was updated), because of the new implementations. You should either update and play the new version with the mutagen updates or stick to the old one


#276

Here are the things I mentioned Link There are 3 things inside this link

  1. The fixes to Pks Spawnlists, anything without the “override” tag will now only add to an existing spawngroup, so this way it brings it back to how it used to be, also realized that Pks Is somehow missing the spawn of skeletal juggernauts and zombie schorchers (Unless they are evolution only in the mod) also fixes that
  2. Update to the medicines like bandages and first aid kits, since they are now over time in vanilla and IDK if the Pks versions are left instant by default, I fixed them by removing them, only leaving the vanilla ones behind, if it IS by design, ignore comestibles
  3. Added back the ammo vending machines to that particular gunstore variant, since I was always bothered by that change in Pks (you gonna need more ammo for the new mobs anyways) , if you wanna leave it like it was Ignore vbuildings

Thats pretty much all the thinkering I did, hope it helps :smiley:


#277

Seems like skeletal juggernauts are still in the ascension mod. By day 14 I encountered one and it’s just kinda doing its own thing since I don’t have an answer for it yet.


#278

So far so good. Been encountering interesting things. A basement filled with weird horrors and magical books, black potion, difference essences, jabberwock skulls. One bug though – the veinreaver weapon that takes blood essence doesn’t seem to be inflicting any damage in the explosion. Weird.


#279

This was fixed in recent arcana update, this mod’s really cool. It adds a lot.


#280

Oh, I’ll update arcana accordingly then. Thanks for the report!


#281

I’m not sure what’s going wrong, but I built a car with the blobparts and it won’t go. I have two amorphous hearts, plenty of power and it’s lighter than the humvee next to it, so I figure it should drive. I have tried it with just one heart.


#282

Someone’s actually going through the entirety of blazemod and fixing things.
Actually fixing things broke the edits of a fork of a fork I was using to make blazemod barely work, so I’m guessing that’s gonna be a prime suspect.
Gonna look into it

aw man they’re ignoring overrides
I’ll actually have to get off my ass to fix things this time around


#283

Thanks for looking into it and I hope the fix isn’t too hard! Until then, I’ll just swap to electric motors. One of my favorite parts of Ascension is vehicles that can actually take a little pounding. It’s real frustrating when normal zombies can rip apart your military APC with their bare hands.


#284

You should have seen blobcars before I nerfed them, they had infinite hp to represent that they would continually regenerate
of course that stuff can’t be made in modded because it would call for code changes so I just made them durability -1 and called it a day, but it woukd always throw a red error at me on startup telling me x part had invalid hp