"Ascension mod" or: "Winning DDA: the mod"

mod

#224

it’s pretty simple, just the basement changes and it werks, although PK did mention carrion changes might need implementation, although in my PK save I do see plague nymphs and their evolved forms, ect


#225

Doing god’s work man


#226

Hello yes hi
It’s that time of the year again where I do the thing I have been meaning to do for several months

I’m currently updating blazemod (the turrets are getting blacklisted until someone manages to implement the new turret code to work with them) and PK ( so it doesn’t crash on startup!) so stay on your toes.


#227

If you update it why not…fix something? Why would you post that you are making an update without fixing something that has an importance to what you plan on updating? What would be the point of an update? 0_o


#228

I think the point is that he’s fixing it so it can actually run rather than crashing with certain turrets. It would be too much unnecessary effort to fix the turrets, so he’s just removing them entirely.


#229

Turrets on a vehicle or turrets on the road like a police blockade?

In either event, I haven’t had any problems with any tank turrets I’ve encountered. I hope he isn’t turning tanks off. Don’t think I’ve ever added a turret to my death mobile…seemed silly =/


#230

Turrets on a vehicle. They cause weirdness sometimes because the way the vanilla game handles vehicle turrets was recently changed but Blazemod had it’s own system, so having old Blazemod in an updated game causes inconsistencies and weird shit happens. The easiest way to fix it is to just remove the turret system added by one of them and keep the other.


#231

The racks are a key example. A lot of BlazeMod turrets run off of racks and racks are basically 60L jugs filled with solids which stopped working a while back


#232

because that’s a lot of actual work
meanwhile the game crashes when you try to run it now and turrets are broken to boot
so right now I’m trying to make it not crash

and yes I’m talking about blazemod’s turrets, not the actual turrets
like, the harpoon gun and hypervelocity drive and ripper and stuff

EDIT:
Ok, I removed more_location as a dependency (it was just to add a few secret doors anyway I just copypasted those into the main mod) and I updated the .json. I got some bug with the bfg vehicle for some reason so I’m gonna need to fix that one too (oh wait that was fixe din nu-PK that’s fine) (oh wait nope that doesn’t work still fuck) (oh wait it does when i use the new pk but I don’t want to do the whole thing where I do the changes again fuck I’ll have to cherrypick again) (OKAY I FIXED IT turns out I hadn’t done a pretty important thing that is moving the actual changed files into the actual mod I was compiling) (oh no but now there’s another bug about damage dice or something) (WHAT IS THIS MONSTER I CAN’T FIND IT BY LOOKING AT THE DICE OH MY GOD WHERE IS IT IT’S LITERALLY THE ONLY LINE THAT GIVES AN ERROR)

Okay so I’m leaving that in
I have no clue what that is I’ve been at this for half an hour looking at something that shouldn’t even exist

@darktoes
yep
off they go


#233

NEW VERSION

-Removed the more locations mod dependency so it doesn’t clash with PK!
-PK updated so it doesn’t crash at startup!
-Worth the wait (or at least it should work now)
-(IGNORE THE DAMAGE DICE ERROR AT STARTUP I HAVE NO IDEA WHAT CAUSES THAT I KNOW IT’S PK BUT I CAN’T FIX IT SORRY JUST IGNORE THAT)

Stay tuned for the actual damage die fix


#234

Hi there, @trelatyraelis!
First and foremost, thank you for making this mod; I’m looking forward to finally getting to try it. I just did a git pull from the base repo for CDDA, and then downloaded the latest tgz of Ascension (from about 6 hours ago or so) and tried to run it, but I’m getting two errors:

src/iexamine.cpp:3550 [iexamine_function iexamine_function_from_string(const std::string &)] Could not find an iexamine function matching 'autodoc'!

And yet, when I look, I find it:

src/iexamine.cpp:void iexamine::autodoc( player &p, const tripoint &examp )

The second error I’m getting is regarding the FIREBALL death function:

invalid monster death function: "FIREBALL"

When I go digging for this, I can find it in both src/mondeath.ccp and src/mondeath.h.

I feel like I’m missing something small, here. Any ideas?
Many thanks in advance!
Iri


#235

Okay, wow do I feel stupid. I had downloaded them, but have been so tired that I forgot to actually compile them. My apologies.

When I have a feeling I’m missing something small, I usually am. :\


#236

As a followup: recompilation did not work, and spewed all kinds of errors. I deleted the base dir and did a full git clone, then copied the Ascension mods back into the directory. A couple of minor errors, but now we’re good to go!


#237

'Aght good stuff

Still trying and failing to fix the damage_dice_error, that’s the only worldgen error I get when I try to load ascension & Co. I know it’s from PK’s main repo, but I can’t find it for the life of me, there’s no monster that fits the requirements (damage dice 2, morale 30, damage sides 2).
Doesn’t help that the main PK github still doesn’t have the worldgen fixes yet, so I had to pull only the unofficially updated regional_settings.json @dissociativity was so kind to upload. Also I haven’t touched turrets yet (not even blacklisted them). Some still work, but most of them are still completely broken.


#238

There’s a bug with the built-in Ballista rack in the attached Blazemod where using it causes it to switch to the harpoon rack, and then using it again causes it to switch to the hoppers (Smaller racks) for crossbow bolts, scrap, etc.

I fixed it by changing the use action of the harpoon rack to Hbolt_rack instead of just bolt_rack, where Hbolt_rack is the ballista rack instead of a crossbow rack, if I’m making any sense.

I’d make a pull request to fix it but I’m not skilled at using git and have trouble getting tortoise to work on my computer.


#239

Ok I thought somebody from the discord would´ve spoken by now but I figured out the damage dice error a couple of weeks back @trelatyraelis, its the mon_bear from Pks rebalance, located on misc.json, apparently after the carrion update the mon_bear_cub tries to copy from a mon_bear, but since there are 2 of them (the mainline one and the PKs ones) this error occurs, I fixed it by simply changing the damage dice from mon_bear in the aforementioned Json, hope it helps, keep up this modpack man Love your work!


#240

ERRORS FROM THE START! Am I the only one seeing this?


#241

Could you be more specific about how you changed it? I’ve got the json up, you don’t really mention here what you did other than ‘changed the damage dice’


#242

Oh dissociativity, well I honestly don’t know how else to explain, I changed the “melee_dice” (line 256) value from 4 to 3, and the error dissapeared,the reason why?not sure, I just know it worked


#243

Great work lads, great work.

I’m gonna pull a new release both with @dissociativity 's new PK health changes and @alexandreiah’s json edit for the damage that just werks to stop the errors at worldgen.
Thanks a lot!