Android Version


#121

My understanding was that save games should be backwards compatible from latest 0.C experimental all the way back to 0.B, can anyone confirm this?

The latest Android build (0.4) no longer stores the keyboard shortcuts in the .sav json file. Instead it creates a separate .shortcuts file alongside the .sav file. This means the Android save games should be 100% interchangeable with the desktop version, so you could set up two-way Dropbox/Google Drive syncing for example and switch between your phone and PC. The .shortcuts file will just be ignored on the desktop build in this case.

So back to your original issue, what actually happens when you try and copy a save game from desktop over to the Android build? Does it crash? Or load in a broken state?


#122

Sorry, I’ve forgot to add this info.
My device is Philips Xenium W8510, with Android 4.2


#123

I think they’re only forward compatible? As in, you can upgrade an older save, but going back isn’t a thing. I may be totally wrong though. I suppose I can go dive the code.


#124

Yep, lib error.
But little bit different.

Error: Cannot load library:
soinfo_link_image(linker.cpp:l
652): could not load library
"libgnustl_shared.so" needed
by “libintl—lite.so”; caused by
|oad_library(linker.cpp:759):
library “libgnustl_shared.so” not found

Alcatel pop c7, 4.2.2


#125

Would one of you please try sideloading this apk, and let me know if it fixes your issue?


#126

Well, it fixed the lib crash, but, unfortunately, game start crashing on launch, the same way as before. For some reason, i can’t solve this by deleting unused tiles, or replacing old config, so, i bet it is not my old problem, but new one. Lets wait for someone else who can test this.
Debug logs are useless as always, tho. Non-critical locale error message, hoder tileset issues (if it’s in the gfx folder), tons of “couldn’t parse color”.


#127

Hatcher, have you tried a clean install? If that doesn’t/didn’t help, I fear the extra optimizations may have pushed the RAM usage beyond what your phone can handle… :frowning:

Edit: Forgot to ask, is it an actual crash, or does it just silently close?


#128

So is the numerical keypad(not on keyboard) active in latest version?

I like using 3 tools of input, even on my tabby.

789
456
123
keypad

and a regular english keyboard


and my mouse =D

Would great to take my tabby with me and play even if it were ascii =)


#129

Not precisely sure what you mean, but… If you’re talking about hardware number pad, it should work(although a peripheral number pad might not be detected properly by SDL, don’t know if we can help that). Num_Lock needs to be set, of course.

P.S.- Mouse support might be kind of iffy. On my equipment, only the left mouse button works. YMMV.


#130

No problem regarding left only for mouse.

Literally getting the SDL error as you wrote. Just tested the google play one.

SDL Error

An error occured while trying to start the application. PLease re-install.

Error: Cannot load library: link_image[1936]: 115 could not load needed library ‘libgnustl_shared.so’ for ‘libintl-lite.so’(load_library[1091]: Library ‘libgnustl_shared.so’ not found)

Sooo…no idea what the heck that is but my access to the net is limited and I may have to leave in like 20 mins =/
…crap you left after you wrote =/

Asus Transformer Pad TF300T 10" 1gb RAM
Android 4.0.3 (because I cannot update, less it may make my system less stable…=/)

Maybe something new in the code cannot work with older versions? Hope not. I can’t update and REALLY want this on my tabby. T_T


#131

Crap, probably missed you, ZoneWizard. There’s an apk in the thread here that should fix that problem. I’m building an update apk to push to Google Play right now, but it’ll be a bit before it’s done.


#132

4.1 Bugfix patch just went live.


#133

Wulfe813,
It works! Clear install fixed the problem and i finally got into main menu. Great job, you guys are awesome!


#134

Glad to hear it, Hatcher. Not at all sure what the issue causing the need for a clean install is, sadly. I can’t seem to reproduce it.


#135

The game now successfully launching ONLY after 2 attempts. New optimisation, lol? I’ll test the perfomance during gameplay and post a report.
… aaand now i doubt i was trying to launch the game TWICE before i deleted and install apk clear. Maybe i did and clear installation really solved that problem. Maybe not and simple update was just enough to start playing. Goldfish memory.
Messing with a vanilla option “allow joystick” now causing weird input delay. It’s not critical, just keep that option on, but im sure in the 0.3 i’ve set this option off without any problems.

If while launch cata is on peak of memory using it will explain some of my problems, but why two attempts, tho?


#136

It could be that the first run is triggering memory clearing, or causing things to be swapped to zram(which your phone probably has), but simply not fast enough to keep the low memory killer from nuking the game. Second time around, you’re starting with more memory available. That’d be my guess. With the heavy optimization, the peak memory usage that occurs during startup is reached quite a bit sooner.


#137

I think they’re only forward compatible? As in, you can upgrade an older save, but going back isn’t a thing. I may be totally wrong though. I suppose I can go dive the code.[/quote]

This is correct, the expected use case is migrating only to new versions, migrating to an old version is not supported and will sometimes break in strange ways. For now the only safe bet is to run the same code version for both installs if you’re going to migrate a save back and forth.

Supporting forward and backward compatability is possible but difficult.


#138

It would probably be easier for us to find a solid means of keeping in sync with the nightlies.


#139

It would probably be easier for us to find a solid means of keeping in sync with the nightlies.[/quote]

I expect so, and it will head off all sorts of other problems too boot.

Short term, let’s coordinate on versions, let me know when you move to a new version, and I can pin that version in the download server and put a link to it on the site.


#140

@Kevin Granade : Is there any simple way to get the hash for the nightly build? Something I could tack into a script, maybe?

Edit: Never mind. I found a solution.