Android Version


#202

It worked! Awesome thank you very much sir!

On a side note why was prm thread locked by Kevin 2 days ago?


#203

Im not a sir im a teen
Also im using pk5.5.7 on android cause i copypasted stuff


#204

Because I locked all the threads that have been idle for over a year. Something about the new system seems to encourage people to necropost like crazy, so I’m just locking down ancient history. If you want to reopen the conversation, open a new topic that links to the old one as outlined here: Site Feature Showcase


Process for reparing 'faulty' engines?
#205

Ah, gotcha famalam, will do just that


#206

i was creating a character for… a fun stunt and i when choosing the starting place and saw a new building:“hermit shack” but when i try to play it always fails to but in the starting point, i tryed 12-15 times


#207

You probably have a world without enough wilderness. Try creating a world with city size less than 2.or widely separated cities


#208

oh, its a default world whit z levels enabled and construction time set to 0


#209

i also tryed to installa mod again, and looked if the “already installed” mods have something in common, but instead i found a animatronic mods that i can’t activate but itsonstalled, its pretty much fnaf 1 and 2 animatronics added… but i wanted to ask, why dosen’t that mod show up? it dosen’t look different from other mods
edit :oh wait, my file explorer is just trash at zips, you don’t unzip whit the umzip, but you try to open the zip, and if you click back in the gistory it gives the unzip options…

but i can’t unzip arcery or pk reblance or cataclysm ++ ¯_(ツ)_/¯


#210

I use es file to extract mods to the mod folder ex:cata++,pk mod etc…


#211

thats what am tryng to do! also have the same file explorer…, it just dosen’t extract, to i up have root?


#212

You dont have to root
just long press the file you want and press the button at the bottom right of the screen then choose extract then choose where to place it


#213

Any updates on the update?


#214

I updated the Android version to a current build (as of a few days ago anyway). Debated whether I should release it since it feels held together with proverbial duct tape and Graywolfe did say he was going to be working on it again. It’s signed with a debug key which means it expires in a year I think, and it’ll most likely require you to uninstall the Google Play version due to conflicting signatures. And obviously you’ll have to enable installation from unknown sources. I’ve also forked his project and uploaded the changes so you can compile it yourself if you don’t trust me.


#215

Wow, good job! I tried playing with the Mxotto+ tiles but it lagged alot. It’s the problem with my phone? I tested the retro tiles and worked fine.


#216

Not sure what phone you have but on my pixel 2, I noticed the lag as well until I went and turned software rendering off. Now it seems to work fine. Awesome work ejseto! i did try to compile a new version myself a few months back but couldn’t figure it out so I’m glad someone smarter than me was able to. :slight_smile:

On a side note is there anyway to hide the Android nav buttons (back, home, recents) when playing? Pixel 2 screen is already pretty small and they are taking up valuable screen real estate… I suspect there are code change required to make it happen?


#217

the more location mod doesnt work it stay stuck at the mapgen weight and exit out of the app

On the other hand i absolutely love it cause i can still play the app even if i exit :slight_smile:


#218

updated version doesnt seem to work with PK rebalance as well, throwing out of the app on worldgen. so sorry


#219

Amazing! But i can’t change the language, is this a build’s you used bug or you compiled it without multilanguage support?


#220

Ah, yeah, I couldn’t get multilanguage support working. I’ll give it another try since I don’t remember what exactly went wrong.

Alright, I think I just made a stupid mistake merging the translations.cpp file lol. Stupid GIT told me to merge something that didn’t have any actual conflicts so I just exited instead of saving so there’s garbage in the file.

Uploaded a new .apk. Cba to test it but theoretically it should work since I just fixed that one file and it compiled fine.

edit: Upon testing, I don’t think that fixed localization. Considering I don’t compile/play with localization, I may or may not be able to fix it. The translation files themselves are almost certainly missing since I would assume they need to be converted from po to mo or some such, which wasn’t in the compilation instructions on a1studmuffin’s repo. I may also have broken something while merging the 2 repos in the first place.


#221

Anyone had any luck running the updated version with PK rebalance? if so which version of PK you used (previous seemed to work with 5.3.5)?