Android Version


#222

No need for rush. The version you took has broken map generation. There’s like ~20 labs and ~10 mansions on each overmap chunk. I do like labs and mansions but not that much.
————
or it’s because Urban Development mod? Shit, now i gotta check it.
————
Nope and nope. It’s broken build, not the mod. I’d create vanilla world, still tons of mansions, labs and sugar houses.
Also — on first launch appears language selection window but only MOTD and names had changed.


#223

You can just merge last one with 5.3.5’s overmap_specials.json. Diary farm— that’s what causing troubles.


#224

you mean i can use ejseto’s version and replace that file from PK rebalance or from previous version of cata? sorry if i sound lame, but by 5.3.5 i meant PK version which is working alright with the android version.

PS. i found out killer japanese desert mod , works better than desert_test.

It wouldnt work with any of the japanese mods as well


#225

Now that the android is updated you no longer need pkm 5.3.5 you can now use the updated version of it
I use the pk mod inside the ascencion mod


#226

thanks, but as i understood from the above statements this current android version requires some tinkering. if you would kindly describe required actions to run it i’d be most grateful


#227

so ejseto’s updated version is based on broken build and there’s no workaround? when i tried running it it crashed during mod load and im absolutely in love with those japanese bandits and desert mods


#228

Build updated to commit 5e762434983ce1cb6e98f02e226950e9d4683689 (fresh pull from ~15 minutes ago). Localization still doesn’t work (the option is there, but stuff is still untranslated, so don’t get your hopes up).

https://github.com/ejseto/Cataclysm-DDA-Android/releases/download/0.1a/CataclysmDDA-debug.apk


#229

Map generation is still broken. Tons of mansions (sometime in the middle of wilderness), sugar houses and labs. I bet it’s a ports issue.
World can become something playable only with low city sizes and city distances. Otherwise there’s labs, labs, mansions, labs and labs.


#230

Well, I’m not the developer, I just merged the repos as well as I could (i.e. to the point that it compiles). You’ll have to wait for an official update. I wouldn’t even know where to begin, or whether what you say isn’t a problem on your end (I don’t see anyone else complaining, and almost no one else even posting).

Also, what is your frame of reference? Are you comparing this to Windows experimental builds, or the official Android version? Because my Windows version has tons of things repeated. If I see one mansion, I usually get 2 more. If I see 1 lab, it usually has 2 or 3 brothers. I don’t think this is on my end. This is from my current game, granted the last time I updated was probably about a month ago, but you can see 2 labs right next to each other with a 3rd on the same map screen, and 2 of those large power stations in very close proximity.


#231

So is the new version compatible with PK mod or no?


#232

Yes it is compatible(you no longer need 5.3.5)


#233

So there’s an update on the play store and keeps exiting me every time i play a character


#234

Same here.
Game exits either at entering a world or shortly after…

Is there a place where I could download previous version?


#235

You could try ejseto version just above


#236

Thanks. I will try.

EDIT:
First try went better, menaged to play short while (create world, character, and scout house where game started) but than I moved my phone and it decided to switch to portate mode, and game crashed…

Made it fixed in landscape mode and played little more. For now looks good. I will try more when I have time.


#237

Its also on the experimental where turret hit own vehicle


#238

Well I’m not going to update it if nobody cares (this thread wasn’t even posted in for 3 weeks). It takes 10-15 minutes to just build it (with 12 threads) assuming there isn’t anything significant I need to manually merge. The Windows build is broken btw. Some headers are missing (the fix isn’t merged yet, despite breaking the build, but at least I didn’t have to actually fix it myself), and there’s an extra } in overmap.cpp. Someone also misspelled “veggy” as “veggie” in the coffee bean item definitions causing debug errors. There’s also debug errors with anthills and acid_anthills from (I assume, since I’ve never heard of acid_anthills) something that was merged a few hours ago. Oh, and look, right after that extra } that (also) breaks the build there’s a line about acid_anthills.

Don’t people compile their changes and test them? I did (though I guess that was the entire point), and I didn’t even change anything.

Here’s a freshly updated version, anthill error message included, dunno if it actually breaks anything. You guys can post to remind me to update it when it gets fixed in the main repo. Or remain silent if you don’t care, that’s fine too.


#239

There is a type of people who now shit about making games work but enjoy them (like me) I was happy with google store version but it broke recently so came here looking for working version.

And I need to thank everybody working on it. It is great game and in my current life situation playing it mobile is dream come true!


#240

Im really sorry for not saying it sooner cause i thought it was gonna be a hassle(i dont know anything about computering :confused: )
I also tried to spread this app on my classmates so more people can play this awesome game:):smiley:


#241

It’s not really a hassle, but it does take long enough that I’m not going to bother if there’s no interest. Updated to include a minor fix (missing/extra commas) that gets rid of that anthill error.

Actually, is there a need for me to keep doing this? Seems like the Play Store version is getting updated again.