Android Version


#181

a1studmuffin I have a question:

I’m trying to get the PAGE_UP and PAGE_DOWN keys to work with the CDDA Keyboard I’m working on. Android docs say the keycodes are 92 and 93 as per https://developer.android.com/reference/android/view/KeyEvent.html#KEYCODE_PAGE_DOWN but (Android) Hacker’s keyboard has their keycodes as -92 and -93. None of these work

The standard windows keycodes for PAGE_UP and PAGE_DOWN are 33 and 34. Trying to send these however just sends the keys “!” and “;”

I think that I need to edit SDLActivity to convert the keycode… maybe in SDLInputConnection.sendKeyEvent()… but would I just use getUnicodeCharacter()? I’m unsure of what the PAGE_UP keycode should become. Any thoughts?

[quote=“JoeyJoeJoeJrShabadoo, post:180, topic:13348”]Installed and testing now. Looks great so far. Will let you know if I have any problems.

Thanks :)[/quote]
You are welcome. Thanks for testing. Hopefully I can get out a much improved version soon


#182

Latest commit: 4 months ago
Well fuck…


#183

I experience severe lags in the cities, like 3-5 seconds between each turn. What can it be connected with?


#184

New version of CDDA Keyboard is available. The missing keys have been added and the bottom row is just single touch now. It works pretty decent i think. Large screen is recommended (eg. 5.5" 1920x1080)


#185

Check if there are too many stacks of items in your inventory.

Turn off Z-level.


#186

Also having an NPC follower set to auto-pickup can cause hang ups.


#187

Absolutely loving the Android version! Been playing it a bunch recently and finally reached the point of extreme vehicle modding, but I’m having an issue where I can’t scroll through middle panel of the vehicle interaction screen so I can’t see the values for all my batteries. I’ve never gotten this far on the pc version but I’d think that the usual < > keys (auto bound to “next tab” and “previous tab”) would do it, but they don’t seem to do anything here. Am I missing something?


#188

Anybody can update build?


#189

Any idea if the MShock32Xottoplus tileset would be able to be used on the android version? It’s by far my favourite tileset that allows you to see items equipped on your character.

Edit: Nevermind, didn’t realise it was as easy to import other tilesets in this version. It works perfectly!


#190

I’m currently new to this game… I love it but the mods makes this game better. There seemed to be a problem with the mods “Arcana” and “Animatronics” though. Saw them with my trusty ol file explorer. I don’t know whether this thing had been talked about before or something but one thing is fo sure… This looks awesome.


#191

I’m absolute trash with android compiling related things, and the last time I modded the game was with a codeblocks setup on windows before Cataclysm was even DDA, BUT if anyone would mind compiling the latest android build from the github, it’s from memory a month or two newer than the most recently published apk and many of us would appreciate it immensely!


#192

my game randomly stopped working, literly, if i try open the game (i am on mobile)it loads whit the Z logo and then it just shows a black screen! i tryed force stop but i don’t want to lose progress so i am tryng to not delete anything, also if i try to open defence or toturial, it says something about imageri guns mod and dosen’t let me open them, idk if this is a bug or no but some enemies and magazines are letters EDIT: i also have the latest google play version EDIT2: darn, i forgot to backup my files before reinstalling… well, lets start again


#193

What you play is not version 0.A.


#195

idk if my post deleted, but if it didn’t, then i want to say that i diden’t relise the post was 1 year old… (i bet at the “i want to say” part you thought that there was gonna be an apology or something emotional… :eggplant:


#196

Post made in the wrong thread, moved to better location, it’s routine :woman_shrugging:


#197

Has anyone had any luck getting pk’s rebalance to work with android version? Got errors about ground cover when I last tried. I’m using the patch included with the mod but it isn’t working.


#198

i always thought that the rebalance mod was always on the android version,becose i get more zombies then other types of zombies


#199

Overwriting the file with one from android patch archive can fix it, but map generation will be broken all the same. I think 0.4.7 is incompatible with latest PK release, for now.
Ill try launch older version of the mod
upd: 5.3.5 works fine


#200

I tried making a new world using 5.3.5 with the android patch and still got errors regarding overmap terrain ID


#201

Just use 5.3.5 without the patch that is how i did it