Mutation Changes mod

mod

#41

I figured you should know that the mod isn’t downloading through the launcher, I think it’s because the launcher is looking at the dropbox link for the older version of the mod and some users are reporting issues with dropbox-hosted mods on GitHub.


#42

Hmm. Then what do you suggest i do to solve this…? Sorry if i am not so useful here but i’m still a newbie : /


#43

Well I managed to install the mod manually into the mods folder and make sure it was named Mutations_Changes for now. The issue is with dropbox’s links, maybe you could provide a quick update to the readme for those doing a manual install in the meantime.


#44

Umm. I still don’t know very much what are you talking about… But i’m gonna do what i can :3


#45

Yeah i think it’s done. I updated the readme to tell the users that it may not auto download with the cdda launcher and that they should download it manually, that was the issue isn’t it?


#46

I think that was the issue, but now with the latest update, or at least the second most recent one, there are changes to the mutation categories. It’s looking for threshold_mut regarding the Tortoise mutation.


Error: data/mods//Mutation_Changes/mutation_category.json: line 2:5: member not found: threshold_mut
[
{
^
“type” : “mutation_category”,
“id” : “mutation_tortoise”,

FUNCTION : bool main_menu:new_character_tab()
FILE : src/main_menu.cpp
LINE : 638

Looking at the base mutation_category.json file for the normal data/json directory, there has to be instead of “category” : “TORTOISE”, it should be “threshold_mut” : “THRESH_TORTOISE”, because several mutations are looking for the THRESH_TORTOISE flag such as the grazer mutation. I’ll check and edit this post to see if changing the line of “category” : “TORTOISE” works or not.

edit: found the fix. You need to replace “category” : “TORTOISE” with “threshold_mut” : “THRESH_TORTOISE” and then do the same with the Chimera entry, with it’s “threshold_mut” entry being “THRESH_CHIMERA” and that should allow the game to load. Also, make sure the entry for Chimera’s id is CHIMERA, like Tortoise’s id should be “TORTOISE” since the mutations.json file in the mod folder is still using that for the category. ctrl+f tortoise in the mod’s mutations.json file will show the category being “TORTOISE” and not what the previous entry was. The world loads up with no errors at this point.


#47

Ok. bugfix incoming x3 Also thank you for helping and guiding me on this : D

Edit: Ok i did it, is it normal now?


#48

It looks like it works, you’ll need to keep the manual download available until the launcher is fixed with dropbox links, or find a way to get the mod’s new url to the github link instead of dropbox.


#49

im wondering were are the rest of the mutagens i went the lizard route and cant make more now


#50

Just a head’s up to the person maintaining the mod, due to a recent change in lab scenarios to keep people from spawning outside the lab, the allowed_locs section in the mod’s scenarios.json needs to have the stairs and finale entries removed with the only permitted allowed_loc being [“lab_escape_cells”] or else the game will crash with several error messages regarding invalid starting locations. This is a very simply fix to keep the mod from wrecking the game.


#51

DEBUG : Error: data/mods//Mutation changes (fixed)//mutation_category.json: line 2:5: member not found: threshold_mut

[
{
^

    "type" : "mutation_category",
    "id" : "mutation_tortoise",

FUNCTION : bool main_menu::new_character_tab()
FILE : src/main_menu.cpp
LINE : 675

It’s the hydra of bugfixin.


#52

Good to know. I’mma try this.


#53

I should load up the game again and do a teenage mutant ninja turtle run.

That was supposed to be in response to PeevedPenguine adding tortoise mutants.


A wandering updater appears! Works with B8166 (lazy b8212 update in comments)
#54

Do this mod and the compatibility patch stil l work and maybe do anybody have a custom versino of it?


#55

I have Bl4nk’s that I managed to fix the errors with for Experimental Version 0.C-31523; I’ll make a drop box for it and upload it here; if either Bl4nk or OP (Peeved_Penguin) asks me to take it down, I will.

Expect an edit soon

Edit: Linky link!

Edit 2: Uploaded a 7zip version


#56

I couldn’t get your version to download, so I grabbed Bl4nk’s copy. It seems to run ok, but holy crap…Who’s idea was it to copy the entire mutations.json from an old version of cata, and sprinkle new mutations through the file like mouse turds in the cabinet? Is that the only way to add mutations? I hope not. I’ll be poking at it when I get my current setup where I want it.


#58

A good number of mutation effects, the more exotic ones anyway, have hard-coded effects and the best most can do is to alter the .JSON files for the time-being to add new mutations.


#59

'Just to let everyone know, I uploaded a 7zip version for those who use 7zip


#60

hey Hercules exactly what changes did you make? because Ive done some changes myself to mutations.json and i wanna know if theres anything in there i need. Oh, and i noticed you didnt include the fix to the issue Naikor was talking about.


#61

Awhile ago there was an update that changed how mutations were categorized. For example, let’s look at the mutation “Good Hearing”

             Before

        "type" : "mutation",
    "id" : "GOODHEARING",
    "name" : "Good Hearing",
    "points" : 1,
    "description" : "Your hearing is better than average, and you can hear distant sounds more easily.",
    "starting_trait" : true,
    "category" : ["MUTCAT_ALPHA"],
    "cancels" : ["BADHEARING"]

              After

    "type" : "mutation",
    "id" : "GOODHEARING",
    "name" : "Good Hearing",
    "points" : 1,
    "description" : "Your hearing is better than average, and you can hear distant sounds more easily.",
    "starting_trait" : true,
    "category" : ["ALPHA", "MOUSE"],
    "cancels" : ["BADHEARING"]

Looking at the category, you can see that they removed the “MUTCAT” prefix before which Mutation-category it is. When this update first came out, I tried the mod with it and it gave a bunch of errors about the mutation category. So with some free time on my hands, I fixed up the mod to work with the (at the time) most recent update.
About that Nalkor said. I didn’t notice he was talking about a spawning bug/issue with the mod so I didn’t really fix it, as I didn’t know it was there & my main priority was fixing the mutation category of the mod to play nice with the game. I currently don’t have the time right now to fix it, but Malkeus made the fix over at “A wandering updater appears!”. Which, doing a quick test, worked fine.