Mutation Changes mod

mod

#21

As much as I am liking the look of this mod, I’m afraid I have to report a bug with it. I am finding it impossible to get any sort of tail other than stubby, even with the mutation menu. I just get spammed with the message that I have lost the stubby tail and have gained a mutation called stubby tail. For reference this was the only mod plugged in at the time of the testing. Game version: 0.C-18874-g3b8f09c.


#22

Alright, thanks a ton for reporting the bug. I fixed it and updated the file in the link in the OP. Check it out for the fixed version of the mod.


#23

After some more messing around in the testing world, I have determined that there is still slight problem with tails. Specifically fluffy tail and cattle tail. Selecting either causes message spam about stubby tail turning into long tail and long tail into stubby tail. Other than that, really liking this mod.


#24

Thank you very much for reporting this bug, and my sincerest apologies for allowing this through my own Q&A process. I have updated the file in the link in the OP with the corrected version.


#25

I made a patch to merge this great mod with PK’s latest Rebalancing version.


#26

Could you post the patch and instructions on how to use it?


#27

https://drive.google.com/file/d/0B2LKlCxhWTlWM1ZqaUpWanJSTlk/view?usp=sharing is the patch use 7zip to open it install in mod directory and enable after mutation changes and PKs_Rebalancing. Be warned though i have a few person edits to the mutations including stab attack for spider arms ok.


#28

Made a minor update to the mod it now should force the activation of both required mods in the right order


#29

Awesome. I’ve been considering piggy backing a mutant branch of my own onto this mod, but for now as long as it makes things compatible with PK’s stuff, we’re good.


#30

Playing with this mod, I ran into a problem:

I mutated ‘Strong’. This is fine.

I took my helmet off to put on a different helment and it says I can’t wear helmets.

I cheat Strong away. The helmet goes on fine. The modifier to strength remains?


#31

[quote=“Umbral Reaver, post:30, topic:12362”]Playing with this mod, I ran into a problem:

I mutated ‘Strong’. This is fine.

I took my helmet off to put on a different helment and it says I can’t wear helmets.

I cheat Strong away. The helmet goes on fine. The modifier to strength remains?[/quote]

That seems very odd. I checked both the code and tried replicating what you have explained and did not encounter anything that would even suggest that this would happen. I doubt the problem is with my mod and might be with some other modification that you are running. Whatever the cause might be however, I cannot help you with it because I cannot replicate it or find anything in the code of my mod that might cause it.


#32

Hey Peeved, awesome mod man. I’ve been using it extensively in my last few play throughs and even piggy backed my own mutation branch into the game using it. Keep up the good work man. =D


#33

This mod conflicts with BlazeMod due to the blacklist mutagen.


#34

Anyone know if this is likely to still be compatible?


#35

This is still compatible with the current experimental as far as I was able to determine.


#36

When I last tried this mod (downloaded through the Launcher, IIRC), I did some messing around with it. I found it was impossible to mutate the “Chimerical Protection” mutation because it was impossible to have both Scales and Light Fur at the same time. It’d just keep reverting to Rough Skin. You’d have to make Light Fur and Scales not cancel each other out.


#37

It doesn’t seem to be working right with build 6984. I was able to make mutagens and serums, but they had no effect. I removed the mod from my world and cheated in the two mutagens and one serum that I’d used to no effect and verified that the unmodded versions still worked.


#38

Can confirm same issue here, made mutagen serum, took it (with syringe in inventory) nothing happened. loaded up a test game where I was able to find 2 kinds of mutagenic serum in the wish list, where one kind did nothing at all and the other kind worked just fine. I dont remember the exact name but one was **_mutagenic and the other was **_mutagenicM and only one of the two worked.


#39

Umm… Do someone have the intention to update and fix this mod to the latest experimentals because i run it and have certain problems between mutations and a little on bugs. Also im new here so please tell me if i do something wrong. :3


#40

Well. It costed time and work but i finally managed to make the mod work again. :smiley: But i dunno if its good or nice but i like it, I fixed the mod and added some new mutations and things. And i’m planning in updating it with more nice things but i’m running low on ideas so i’m going to let the fixed version in here.
-> https://github.com/Bl4nked/Mutation-Changes-Mod-Fix- And be open to suggestions :3

-Also i don’t want to make the original author mad in any way.

-I did this “fix” so that other people can play it in the newer versions with no problem and with the best intentions.

-And Lastly there is one little problem which can be fixed in the json files of your Cataclysm
but i suppose that it isn’t so complicated to you… As long as you know about the search/replace/find commands you are going ok. Also this is the first thing i modded for cataclysm and share it with the world so please if you don’t like it…
Dun’ kill me pls i’m begging u D: