CDDA Game Launcher (Automatic updates and more!)


#81

[quote=“Bob_Namg, post:79, topic:11168”]Careful, whichever directory is set to host the output files gets wiped, as in anything that was in that folder gets deleted and replaced.
This is obviously unintentional but I couldn’t imagine the horror if I had set the output directory to my Desktop…[/quote]

Nothing should be deleted, only moved in the previous_version subdirectory.


#82

Version 1.0 of the CDDA Game Launcher has been released. This version should be stable enough for most people to use. It includes new save backups features with automatic backup options that can be useful for a few of you.

The only 2 features left in my plan are the tileset manager and the font presets. If you want to suggest new feature, you can do so on Github.

Thanks to everyone who tried the previous versions. Thanks to those who helped me fix the different bugs so far.

If you want to help us translate the game, we currently have translations for English, Russian and French. I can provide anyone who would want to translate the launcher into another language with all the tools, help and support to do so. Get in touch with me.

If you use and like the launcher, consider donating bitcoins to 15SxanjS9CELTqVRCeEKgzFKYCCvSDLdsZ.


#83

I love the mod manager!!!


#84

I found this initially on the Reddit forum. Great utility. I think it would be a good idea to link directly to it from the main page.


#85

I want to report 2 bugs:

  • The 1.3.2 version moving itself to the previous_version directory when updating the game.
  • Also it crashes when backuping the save file.

#86

[code]CDDA Game Launcher version: 1.3.2
Type: <class ‘OSError’>
Value: [Errno 28] No space left on device
Traceback:
File “cddagl\ui.py”, line 2384, in timeout

File “shutil.py”, line 539, in move
File “shutil.py”, line 245, in copy2
File “shutil.py”, line 110, in copyfile
File “shutil.py”, line 70, in copyfileobj
[/code]


#87

There is not enough free space on your disk to backup your save or to update the game.


#88

There is not enough free space on your disk to backup your save or to update the game.[/quote]
Yes, I know that. It is probably better to check available disk space and notify user prior to starting the backup.


#89

[code]CDDA Game Launcher version: 0.7.5
Type: <class ‘UnicodeDecodeError’>
Value: ‘cp932’ codec can’t decode byte 0xef in position 0: illegal multibyte sequence
Traceback:
File “cddagl\ui.py”, line 1781, in copy_next_dir

File “cddagl\ui.py”, line 1832, in post_extraction_step2
File “cddagl\ui.py”, line 1736, in asset_name
[/code]


#90

Launcher crashes whenever i try to backup the save game. Help ?


#91

Update takes about half an hour, and then crashes with the error that Dosbally pointed out.


#92

Are you still having those issues with the latest version of the launcher?

The backup crash might still be happening but the other ones should be fixed by now.


#93

Never got to thank the creator of this launcher, Thanks for this, keep up the good work, nice with the changelog :slight_smile:


#94

nice update


#95

I’m running through Wine in Linux Mint Sarah so I’m not sure if this error is occurring for people running through actual Windows. Updates and installing mods is working fine, but when I use the launcher to start the game while the game does start instead of closing properly the launcher crashes giving this error message:

Unhandled exception: unimplemented function msvcr100.dll._wfindnext32 called in 32-bit code (0x7b83936c). Register dump: CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b EIP:7b83936c ESP:006487a4 EBP:00648828 EFLAGS:00000212( - -- I -A- - ) EAX:7b82694d EBX:00000004 ECX:006487d0 EDX:00648854 ESI:7ed27980 EDI:00648a9c Stack dump: 0x006487a4: 7bc36796 006487d0 cbbabd00 006487d0 0x006487b4: 00000003 00648808 80000100 00000001 0x006487c4: 00000000 7b83936c 00000002 7ed27980 0x006487d4: 7ed2b29a 00000020 0064acce 00001000 0x006487e4: 00000000 7ec83571 00000000 0014be38 0x006487f4: 0064acce 00000000 0000fde9 00000002 Backtrace: =>0 0x7b83936c in kernel32 (+0x2936c) (0x00648828) 1 0x7ed27937 in msvcr100 (+0x17936) (0x00648868) 2 0x7ed26301 in msvcr100 (+0x16300) (0x0064cce8) 3 0x00404d02 in cdda-launcher (+0x4d01) (0x0064cce8) 4 0x00402cdb in cdda-launcher (+0x2cda) (0x0064fd28) 5 0x004015a6 in cdda-launcher (+0x15a5) (0x0064fd58) 6 0x00409e5d in cdda-launcher (+0x9e5c) (0x0064fd78) 7 0x004013f0 in cdda-launcher (+0x13ef) (0x0064fe40) 8 0x7b85a3fc call_process_entry+0xb() in kernel32 (0x0064fe58) 9 0x7b85b3ea ExitProcess+0xfe9() in kernel32 (0x0064fe88) 10 0x7bc7703c call_thread_func_wrapper+0xb() in ntdll (0x0064fea8) 11 0x7bc79e5d call_thread_func+0xfc() in ntdll (0x0064ffa8) 12 0x7bc7701a RtlRaiseException+0x21() in ntdll (0x0064ffc8) 13 0x7bc4d277 call_dll_entry_point+0x756() in ntdll (0x0064ffe8) 14 0xf75aa33d wine_call_on_stack+0x1c() in libwine.so.1 (0x00000000) 15 0xf75aa4a0 wine_switch_to_stack+0x1f() in libwine.so.1 (0xff9fb648) 16 0x7bc528d7 LdrInitializeThunk+0x336() in ntdll (0xff9fb6a8) 17 0x7b861029 __wine_kernel_init+0x888() in kernel32 (0xff9fc818) 18 0x7bc52e33 __wine_process_init+0x152() in ntdll (0xff9fc888) 19 0xf75a7dff wine_init+0x30e() in libwine.so.1 (0xff9fc8e8) 20 0x7bf00d42 main+0x81() in <wine-loader> (0xff9fcd38) 21 0xf73c3637 __libc_start_main+0xf6() in libc.so.6 (0x00000000) 0x7b83936c: addl $12,%esp Modules: Module Address Debug info Name (51 modules) PE 400000- 449000 Export cdda-launcher ELF 7b800000-7ba54000 Dwarf kernel32<elf> \-PE 7b810000-7ba54000 \ kernel32 ELF 7bc00000-7bcda000 Dwarf ntdll<elf> \-PE 7bc10000-7bcda000 \ ntdll ELF 7bf00000-7bf04000 Dwarf <wine-loader> ELF 7e4ba000-7e4c1000 Deferred libxfixes.so.3 ELF 7e4c1000-7e4cc000 Deferred libxcursor.so.1 ELF 7e4cc000-7e4df000 Deferred libxi.so.6 ELF 7e4df000-7e4e3000 Deferred libxcomposite.so.1 ELF 7e4e3000-7e4f0000 Deferred libxrandr.so.2 ELF 7e4f0000-7e4fc000 Deferred libxrender.so.1 ELF 7e4fc000-7e503000 Deferred libxxf86vm.so.1 ELF 7e503000-7e507000 Deferred libxinerama.so.1 ELF 7e507000-7e50e000 Deferred libxdmcp.so.6 ELF 7e50e000-7e512000 Deferred libxau.so.6 ELF 7e512000-7e538000 Deferred libxcb.so.1 ELF 7e538000-7e683000 Deferred libx11.so.6 ELF 7e683000-7e698000 Deferred libxext.so.6 ELF 7e6ba000-7e747000 Deferred winex11<elf> \-PE 7e6c0000-7e747000 \ winex11 ELF 7e7cd000-7e7f7000 Deferred libexpat.so.1 ELF 7e7f7000-7e840000 Deferred libfontconfig.so.1 ELF 7e840000-7e86b000 Deferred libpng12.so.0 ELF 7e86b000-7e886000 Deferred libz.so.1 ELF 7e886000-7e936000 Deferred libfreetype.so.6 ELF 7e958000-7e98c000 Deferred ws2_32<elf> \-PE 7e960000-7e98c000 \ ws2_32 ELF 7e98c000-7e9f8000 Deferred advapi32<elf> \-PE 7e9a0000-7e9f8000 \ advapi32 ELF 7e9f8000-7eb0f000 Deferred gdi32<elf> \-PE 7ea00000-7eb0f000 \ gdi32 ELF 7eb0f000-7ec5d000 Deferred user32<elf> \-PE 7eb20000-7ec5d000 \ user32 ELF 7ec5d000-7ed0c000 Deferred msvcrt<elf> \-PE 7ec70000-7ed0c000 \ msvcrt ELF 7ed0c000-7ed44000 Dwarf msvcr100<elf> \-PE 7ed10000-7ed44000 \ msvcr100 ELF 7ed44000-7ed57000 Deferred libnss_files.so.2 ELF 7ed57000-7ed64000 Deferred libnss_nis.so.2 ELF 7ed64000-7ed7f000 Deferred libnsl.so.1 ELF 7ed7f000-7ed89000 Deferred libnss_compat.so.2 ELF 7ef89000-7efde000 Deferred libm.so.6 ELF 7efe7000-7f000000 Deferred version<elf> \-PE 7eff0000-7f000000 \ version ELF f73a6000-f73ab000 Deferred libdl.so.2 ELF f73ab000-f7561000 Dwarf libc.so.6 ELF f7562000-f757f000 Deferred libpthread.so.0 ELF f75a1000-f7756000 Dwarf libwine.so.1 ELF f7758000-f777d000 Deferred ld-linux.so.2 ELF f777f000-f7780000 Deferred [vdso].so Threads: process tid prio (all id:s are in hex) 0000000e services.exe 0000001d 0 0000001c 0 00000014 0 00000010 0 0000000f 0 00000012 winedevice.exe 0000001b 0 00000018 0 00000017 0 00000013 0 00000019 plugplay.exe 0000001f 0 0000001e 0 0000001a 0 00000021 explorer.exe 00000023 0 00000022 0 00000024 (D) Z:\home\user1\Desktop\cdda-launcher.exe 00000025 0 <== 00000040 cataclysm-tiles.exe 00000028 0 00000029 2 0000000d 15 00000009 0 0000000b 0 00000047 15 00000046 0 00000045 0 00000044 0 00000041 0 System information: Wine build: wine-1.6.2 Platform: i386 (WOW64) Host system: Linux Host version: 4.4.0-21-generic

It’s only a minor annoyance, I can launch it manually instead of through the launcher. The launcher still makes updating far easier especially with the hoops I have to jump through in the command line if I want to try using the linux version. I just thought the issue should be mentioned.

Edit: Turns out that it’s not just on starting a game with the launcher. It crashes whenever I close it.


#96

Hey proxiehunter,

From when I can see of this crash description, it seems like the launcher is using a win32 API that are not implemented by Wine. This might be a duplicate issue that someone else already reported.

It’s a little harder for me to support players using Wine, but if you report the issue on Github, I might eventually take a look at it and see if I can resolve it.


#97

yeah, I don’t know what changed but it looks like wine doesn’t work for this anymore.


#98

Other than the crash on closing the launcher it’s been working fine for me.

Edit: To be clear the game does not crash. The game loads and plays just fine. It’s just that whenever the launcher should close it instead crashes.


#99

I used to run CDDA launcher and tiles.exe separate, but inside the same wrapper, and just use the launcher for updates, then change the execution file over. But that hasn’t been necesary in a while, unfortunately my launcher doesn’t seem to want to not crash since I re DLed. I may have to retry from scratch.


#100

My issue of the launcher crashing appears to be solved. Solution: Update to newest version of Wine. The version downloaded through the Linux software manager is about two or three versions out of date. Now that I’m running the most current version the launcher no longer crashes. I suggest any Linux users experiencing issues try the same.