Cataclysm++ Mod

mod

#621

It is still being supported but I haven’t done a release in onedrive for a
while. Been busy with a few things and I lost my login to the forums :stuck_out_tongue:
Replying by email. Planned a few things but might take a while. The version
in github by pressing the green download button should work.


#622

Thanks. I’ll see if that works with my next character.


#623

The version linked in the github in this thread has the same error. The repository the launcher links to is apparently the place to go for the current version. Thanks.


#624

dude just use the launcher, it will allways give you the latest version.


#625

Back when I first started playing there were a number of mods where that wasn’t true. The version in the thread for some mods had often not been added to the repository yet.

Also until the complete reinstall that fixed my issue with crashing I wasn’t seeing this mod in the repository.


#626

Uh i can’t find the recipe for the goo jerrycan in when im playing with your mod, neither the item in the debug menu. Is that a bug or it’s just not implemented ATM?


#627

I’ve occasionally gotten a quest from an NPC to kill the Bioweapon Apophis. The NPC says that the map to Apophis’ location is “in the locker” but they give no indication where the locker is. Even when I’ve gotten it from an NPC in an Evac shelter it hasn’t seemed to be in the evac shelter’s locker.

Suggested fixes: Have the NPC hand the player the map like an NPC who wants their computer files hands the player a thumbdrive.

Or: Use the code from the computer files quest to put the map in “the NPC’s house” like that quest places a powered on computer.


#629

The quest is broken, because you’re supposed to get that from a specific NPC, not just some randomly generated one, static or otherwise. The NPC in question is the head scientist in the Makeshift Command Center.


#630

A lot of flags were changed causing the mod to pop errors left and right. “gun_bionic” is for some reason now “bionic_gun”. “Toggled” is now “bionic_toggled”. “Weapon_bionic” is now “bionic_weapon”. I’m not sure what these changes were meant to accomplish besides making mods made prior to the changes pop errors when enabled.

Here’s a version with tags fixed until it can be updated by the original author. https://www.mediafire.com/file/bssj1mvfrrf6pqi/nocs_cata_mod-master.zip


#631

These are just warnings which can be safely ignored - the mod will still work fine.


#632

Alright, it’s been many many months since you have all heard from me… I would like to first and foremost apologies for that. That time period has been a bit hectic and I lost my login to the forum for a little while :stuck_out_tongue:

Anyway, the mod. It’s not dead, I have plans for it. I will continue to address bugs on it; best way to get a hold of me is via the cdda discord or make an issue in github but I will make it a habit to check the forum again, The onedrive link is dead, use the new dropbox link instead on the OP. The github link change too since the mod repository was erased somehow so I made another one; always keep backups of your stuff…

For now, those pesky load errors are gone if you download the mod from the dropbox link or the green button on github. Thank you for everyone’s patience here and I hope you enjoy playing this mod as much as I did making it.


#633

Well, glad to have you back.

Anyway, here’s a bug: NPCs are getting the “Kill Apophis” mission when they aren’t the NPC at the makeshift command center.

Also, not sure if you care or not, but I found the Survivor’s Scout Suit and Survivor’s UPS Rifle to be a tad out of place. Mainly because you shouldn’t be able to craft items that powerful on a whim (at the very least, the latter should involve some kind of book or something).


#634

Aw, a new bug. Thanks for reporting.

And yes, I was thinking about re-balancing; mainly nerfing some stuff. Those two items are part of a book; I could limit the recipe to the book instead of being auto learn.


#635

I made a thread a while ago complaining about how there’s not enough clothing for Mutants, so I did appreciate the Scout Suit in that regard. Still, I think stuffing absolutely everything into it is a tad too powerful for any item.

Perhaps more variations of the Mutant friendly aspect?

EDIT: Also, Kevin said some things about Overmap Specials. Basically, mod makers shouldn’t make something a mandatory overmap special unless it’d break the game without it.


#636

I cant seem to find your mod anymore on github. Can you give us a new link so I can favorite it?


#637

#638

Unsure if this has been mentioned above somewhere, but some feedback regarding added CBMs.

None of them seem to be installable. The item is grouped correctly in the inventory, but does not appear in the "a"ctivate menu and the activate option in the item description menu returns the error “you can’t do anything interesting with your (CBM name)”.

The only two new ones I’ve found so far are the Monomolecular Sword CBM and the Dual Handed Flamethrower CBM. Will test the others and report back.


#639

Most of the ranged weapon overrides for coregame weapons have been moved to c_ranged_override.json. A lot of old override data was removed by adding copy-from.


#640

I use google drive. Monthly fees for a few TB are reasonable, plus it works with Gmail which I use for correspondence.


#641

I tried to install this mod from the Game Launcher (v 1.3.10) but it returns and error “Selected file is a bad achieve file”.

The URL in the launcher brings to a 404 page and the Home Page link seems outdated (http://smf.cataclysmdda.com).

I’ll get the mod from Dropbox but I figured out I would point it out on here, since the launcher is so very handy.

Cheers!