Cataclysm++ Mod

mod

#601

[quote=“Maddremor, post:600, topic:10523”][quote=“Noctifer, post:599, topic:10523”]Thank you for your kind word and glad you enjoy it!

As for you question, a quick comparison to other sheaths revealed no clear problems The only explanation I could have it’s that the max_volume is too high…but even then there is no minimum volume…[/quote]

I have a vague recollection of the minimum volume defaulting to some fraction of the maximum volume instead of 0 if not specified. Don’t take my word for it though.[/quote]

That did it, I added
"min_volume": 0,
before
"max_volume": 10,
and now it sheathes the butcher knife just fine. Excellent!


#602

Updated the mod in the onedrive link once more. I have added a few encounter similar to the mi-go and dead scientist one but with this mod’s NPCs and monsters. Also dropped the number of mandatory terrain even further, I did not know I had it so high…

Same download process, use the onedrive link in the OP. Happy gaming!


#603

Made a decently large update to the mod’s Lore and other misc stuff. Added actual in-game mission for some NPCs, made the Apophis fight happen underground, fixed some NPC unwanted behavior, made changes to terrain like placing walls instead of fences and made the Survivor Holdout not be a freebie anymore by changing the skitter bots to some challenging zombies.

Download process stays the same, use the onedrive link in the OP. Possible gtihub release with changelog soon.


#604

What kind of behavior specifically.


#605

Some NPCs would run off from their intended locations and either be killed or never be found.


#606

Good to know.


#607

[quote=“Taberone, post:597, topic:10523”][quote=“Noctifer, post:596, topic:10523”]Last time I check, I only have 3 required buildings.
Give me a list of your mods to check their required buildings.[/quote]

[ "dda", "Arcana", "DinoMod", "Experimental-Z-Level", "FIC_Weapons", "Medieval_Stuff", "More_Survival_Tools", "RL_Classes", "blazemod", "Tanks", "Touhou", <--- (Doesn't have any locations at all) "boats", "craftgp", "brightnights", "crazy_cataclysm", "deoxymod", "ew_pack", "makeshift", "more_classes_scenarios", "more_locations", "necromancy", "no_npc_food", "nw_pack", "realguns", "Cata++" ]

I’m also getting a “duplicate entries in the professions array”, although that could be a different mod doing it.[/quote]

Did the required buildings in the mods I was using ever get checked?


#608

2 things:
1.The Experimental-Z-Levels and more-Building mods might have issues.
2.My mod had WAY more required building that I though…I fixed that too.


#609

The v5.0 release of this mod is out! It is the same version as the onedrive link but contains a changelog from the previous release. This also make the version in the launcher up-to-date as well.

Also, the OP was update, hadn’t done it since 2016…

For the complete changelog, follow this link.


#610

Noticed something weird: Survivor’s UPS Rifle says 20 charges but it actually seems to use 50 charges?


#611

Forgot to change the description when I made a re-balance on charge cost. Just listen to the one in blue.


#612

Unless its just I haven’t found one yet I am surprised that you cannot find military surplus packs.


#613

Sorry for the late reply but I haven’t been able to test cata stuff recently. I will check when I am able too and will report.


#614

I was hoping to know if those items were even included in a spawn group or whatever they are called. But thank you either way.


#615

Ok I have no idea why but for some reason and I’m am not even sure if its your mod but for some the small electric motor doesn’t actually work as an engine as it doesn’t show up on the engine part of the examine vehicle ui or the control engine ui. I am only asking because I can’t use the electric motor on an electric bicycle and so far your mod is the only one I found that changes that particular motor.

EDIT: Fixed it changed ENABLE_POWER_DRAIN to ENGINE and that appears to have fixed it. It looks like overrides don’t play nice with copy froms.


#616

So I found an organic defusion set (I think it’s supposed to be spelled diffusion) and I think it’s from your mod because it seems similair to the organic infusion set, but I can’t find any info on it in the readme or here. What’s it do?


#617

Rechargeable purifier.


#618

Updated the one drive link and made a hotfix release on github. The update is a bunch of fixes that came to my attention, including a couple errors. This also rebalances the organic infusion set and organic defusion set. All methods of updating are up-to-date-so pick your poison; this includes the onedrive link, github download button, github release and the launcher.


#619

Does this include making it so that the infusion set actually works after the first time it is used?


#620

Is this still seeing support? I got this error when I tried to create a game using the mod:

As well as a notice that the lmg handle and the surv_laser_sight “must have both sight_dispersion and aim_speed set or neither of them set”.