"Ascension mod" or: "Winning DDA: the mod"


#22

The four mods, deleting any previous copies. I know that some of them have been changed from the versions you may have gotten from the launcher so every game update you’ll need to re-install the mods replacing the version the launcher gave you with Ascension version.


#23

Alright. Is there a list of enemies and items I need to kill/gather?


#24

I saw the additions. It’s quite minor stuff.
Honestly the main reason for packaging the other three mods is that there’s some things that are impossible to override without simply editing the mod itself( see:recent acidbomb bug and the impossibility to add death drops to monsters from PK because of their strange transform-near-death abilities that muck up a lot of the calculations). The solution remains the same: It’s best to keep deleting/merging every file before worldgen because of the additions.
Plus, I’m using a fork of blazemod and not the actual blazemod itself, that doesn’t have the obelisk.

@psyxypher
I’m wary of the fact you haven’t gotten a zombie megabear drop. You said you were playing an old version? How about an old version of the mod too? Since I’ve uploaded it we reached 1.0.7, which will probably increase overtime.Honestly I haven’t tested old versions extensively because of the myriads of bugs I had to deal with that were simply fixed by using a new version, while keeping the save. I can’t promise you that if you keep playing an outdated version you’ll be able to finish the quest.
Anyway the components are in the recipe for the altar and there’s a spoiler in the readme plus hints in this thread’s OP.

EDIT:
Tried to explain everything to the best of my abilities in the new opening post.


#25

Obelisk? I am unaware of anything like that in any version of blaze mod.


#26

Well, I’m using the new versions of the mods that came with the launcher. If I need to start a new world, so be it.


#27

Well, I got the mod to work (Just after entering a Trapdoor Spider Pit :< ) but for some reason, the Queen Ant’s flamethrower attack is considered invalid.

EDIT: I also tested it out on a new world…never seen Cataclysm crash like that…


#28

@DeWolf
Yep. It’s a new thing.
@psyxypher
How exactly does that happen? At worldgen ?
Works fine for me both when spawned with debug mode and when I hit her in her lair.


I’m guessing there’s something wrong with [ “FLAMETHROWER”, 20 ],? That’s strange, because that’s also a mainline effect for the Tripod. Try making a new world and debugging that one to see if the same bug appears.


#29

I did. I had the same issue upon loading a world, and another upon spawning a Queen Ant in on a Debug World.

Maybe use the Young Queen Ant’s flamethrower instead?

Here’s a screenshot of the world load crash.


#30

By the look of the parser error it looks like the problem is not the flamethrower, but the dinject from PK’s rebalance main mod that the game cannot read. Every single ant monster has it.

Give it a look, it’s in attack_types.json. Check if you have the same.

{
“type”: “monster_attack”,
“attack_type”: “melee”,
“id”: “ant_dinject”,
“cooldown”: 20,
“move_cost”: 200,
“damage_max_instance”: [
{ “damage_type”: “bash”, “amount”: 9, “armor_multiplier”: 0.85 },
{ “damage_type”: “stab”, “amount”: 3, “armor_multiplier”: 0.85 }
],
“effects”: [
{ “id”: “skunk_spray”, “duration”: 600 },
{ “id”: “infection_minor”, “duration”: 5200, “chance”: 8 }
],
“hit_dmg_u”: “The %1$s stings you!”,
“hit_dmg_npc”: “The %1$s stings !”,
“no_dmg_msg_u”: “The %1$s tries to sting you, but fails to pierce your armor.”,
“no_dmg_msg_npc”: “The %1$s tries to sting , but fails.”
},


#31

Well, I have it in PK’s Rebalancing.

On a side note, is the amount of files in the PK file given with the pack supposed to be so bare? There’s only like, four files in my copy.


#32

Absolutely not. How did that even happen? This is an image of the actual folder in the repo.

Hell man just

download a new experimental
re-download the mod
slap your save and ALL the new mods in. All of them, dawg.
and tell me if that happens again
because if it does this is paranormal shit
Because I’m at the end of my rope here, how the HELL do you have 4 files in there like how do you even
Honestly I can’t even make heads or tails of what the hell is going on with your world


#33

I think the issue was with the download, because I downloaded the latest release and it seems to be just fine.

You’re a good man for helping me. Sorry for causing so much trouble.


#34

Man, I wanna get to the root of this problem, it’s my pleasure
I’m just super weirded out
So, does everything work fine?


#35

No, but I’m starting to think the issue is with the game thinking that whatever is above the “Special Attacks” line is also an attack. In this case, the ant’s Luminance. I tried removing both the Luminance and the Injection (each separately) attack, and each time the new error message involved the line directly above Luminance.

Also, the mods that were in the Ascension pack are all fine, but the ones inside the Winning DDA folder are as I described, with only a few files. Dunno if that was intentional or not, and in my case I was describing something wrong.


#36

Okay, I got it to work…turns out I should have Winning DDA loaded AFTER PK’s Rebalance.

…Please don’t shoot me, I bruise like a banana.


#37

Oh, I didn’t know that at all! I’ve always put ascension last because I picked it last, good one! I’ll add it to the OP.


#38

I don’t bruise like a banana, I bruise like a hooman bean!


#39

I always just picked Winning DDA and it put the other mods in itself. I just assume it’s loading them in the right order.


#40

@psyxypher
Glad to hear that! I hope you have fun and manage to beat the game!


#41

Have the Vortex Engine and Vortex Generator been fixed in this pack? Because it’d be awesome to finally have a use for those damned vortex stones.