Android Version


#425

Try waiting a while, on slow devices may take some time.


#426

Should I use software rendering on a Pixel 2?


#427

It works now it tooks 10 mins


#428

The general rule of thumb with software rendering on Android: try turning it off (ie. use hardware acceleration), and if that works, it should be the most reliable option so stick with that. Some Android devices suffer from rendering glitches using hardware acceleration, in which case you can try software rendering, but this has a few other side effects, like not always recovering properly from switching focus between apps, turning your device on/off etc. Unfortunately all this stuff is device dependent and there’s no easy way to detect in code what will work best, which is why we give you the option in a pre-launch settings screen.


#429

Thanks. Is this considered a hardware acceleration glitch? Some part of the “tool bar” or whatever stopped rendering fully after I hit one of the key.


#430

Nah that’s not a hardware glitch, this what the hardware glitch typically looks like:

Your screenshot looks fine to me. If some of the keyboard shortcuts disappeared after a while of playing, check the Android settings, there is an option to make them auto-remove after X turns to prevent the quick shortcuts row of keys along the bottom from getting too cluttered. You can also flick up on an individual key shortcut to remove it. If you do that to all the key shortcuts, it will reset back to the default shortcuts (usually 0mi).


#431

I constantly play on android and i find it very hard to add mods for my new worlds because the pointer stay still and I can’t see which mods I add when it hits a certain amount.

I often double-click stuff accidentally and add mods that I didn’t intended to use in the run.


#432


Is there anyway to fix this? Sometimes it also blacks out when pulling the keyboard back down which is slightly annoying but i just bring the keyboard back up and down real quick. This always happens when i bring the keyboard up and I tried fiddling with the settings but nothing works.


#433

This looks like a rendering issue, I’m guessing you’ve got software rendering turned off? Try turning it on and restarting the app, or vice versa.


#434

Actually I turned it off and it stopped. Weird. It was on before that.


#435

Yeah, there are a bunch of device-specific issues with both the software and hardware renderer using SDL on Android. Normally one of them works fine though.


#436

I’m not very mobile savvy. How would I install any of these more current builds off of these non play store sites?


#437

Just download the .apk and install it. Then start the game up and wait for a while for it to install the files. Think of the apk as the installer/launcher.


#438

Despite being defunct, you can get the recent .apk if you go to the Android port github page.


#439

Why not just pick the latest nightly version instead?


#440

http://dev.narc.ro/cataclysm/jenkins-latest/Android/Tiles/

I usually update my Android version by this link.
I dunno if there’s another way to do it, but I get the site link from the late Android page.


#441

How do you transfer saves across updates?


#442

I don’t tranfer saves, I play with the character until it dies or I get bored.

Then, and only then I’ll update.


#443

Yeah me too. Those are the nightlies unless I’m wrong.


#444

If you install an APK over an older version of the same app, your data will be preserved (including save games). You’ll see the installer on launch say “Upgrading game data” in this case.

If you uninstall an app, your saves will be deleted with it.

The one exception to this rule is migrating from the Google Play version to the new APKs from Jenkins. Since they have different app IDs under the hood, you can have them both installed at the same time, they’re completely independent of each other. The rules above apply for both apps.

You can manually copy save games from the Google Play version to the new version, but I’d recommend against it as a lot of content has changed in a year or two of experimental updates, so it may work but will break some things in your inventory, may cause map oddities etc.