Android Version


#405

The joystick problem still in the game?


#406

Yep, we need to test and generate a new version of deps.zip using a newer version of SDL that fixes the joystick issue. I haven’t had time to look at it yet. Upgrading SDL is always scary as there are so many device-specific hardware issues on Android that it’s kinda impossible to really say for sure if it’s running reliably, the best we can do is test on all the devices we have amongst the Android devs.


#407

If you guys need help, be sure to message me. I have android development experience if thats helpful lol


#408

Hey, has anyone else noticed really long load times as they get well into exploring? I’m getting near three minutes just to load a saved game.


#409

Game freezes on startup (black screen). Phone Samsung Galaxy S3 Android 4.3. Why this can happen ? Play Store old version work fine.


#410

Have you tried disabling software rendering on the launch screen when you install it? You can clear app data to see it again.


#411

newer versions have map memory, map memory uses more RAM, your device is quite old and likely has too little RAM.


#412

Yes I’m guessing that map memory is involved. But it’s a Galaxy S8 with 4G RAM, and system / apps are only using about 2G.


#413

App not progress to that screen, where you can choose titles/soft rendering options. It seems app not create foldier com.cleverraven.cataclysmdda, not extract anything to it. Build from that link https://drive.google.com/file/d/10TolS0sPxQWOuEfAlEpl6E7FmjTOBgsQ/view?usp=sharing can progress to Z logo, with same freeze after.
Device have 1.35 GB RAM total. So maybe it’s a memory problem indeed.


#414

Update: game installed and run fine. Just took about 20-30 minutes on black screen and then started “intstall data files”


#415

Thanks for being so persistent.
I also waited patiently and it eventually started to install and ran well apart from the virtual joystick issue others have mentioned.


#416

Glad to hear there is hope for a fix eventually :slight_smile:
The virtual joystick moves in random directions often enough to get your character killed pretty frequently.
Amazing port of an awesome game otherwise though, please keep up the great work!


#417

Do anyone know the last update before the joystick problem i cant find it n would like to download it so i can play the game


#418

Is there a way to reset shortcuts at the bottom of the screen? Stuff like “e” and “c” arent showimg up automatically any more.


#419

I upgraded yesterday to 0.c-8101. Ever since, from the time I start making a character, to when Im running around the game world, the game will kinda like flicker like it alt-tabbed, and show a screen with a big Z on it for a few seconds, and the flicker back to where it left off.
Is anyone else having this issue or know whats causing it? Its making the game un-playable for me.


#420

Ehnuhc posted a fixed version back on September 21st.
https://drive.google.com/file/d/1GtGVfX1yct_LLIKWNxNXJ0pEvERLAwi3/view?usp=drivesdk
That one solves the joystick bug, both on my nexus 7 tablet and nexus 5 phone.

I hope the updated SDL they mention makes its way into the main branch soon so we can play the latest version of Cataclysm.


#421

It says the file is trashed


#422

oh, that was the message i got when i tried to download directly from my Android device. For some reason that link doesnt let you download to the device but forces you to save it to your google drive which then trashes the file when it doesnt know what to do with it.
Instead I just downloaded that .apk from my computer and uploaded it to my google drive then download it from there on my tablet/phone… Could just copy it over via usb as well :slight_smile:


#423

Ok thxs ig im just try doing that hopefully i do it right


#424

Bro, i download the latest apk but when i install and run the game, game stuck on “Z” logo screen how i fix this?