Android Version


#344

We didn’t finalize Android app build process yet, so I don’t wanna bother with fdroid submission myself right now.


#345

No problem, It was just a suggestion to take into consideration in the future.


#346

Is anyone else having trouble with the joystick in the newer versions? It seems to keep getting stuck in the top left corner and making me run off in random directions. I can’t figure out what’s wrong with it.


#347

There seems to be a problem with “KawaiiMod” in the latest release. When putting the game in the mod folder, the game crash at startup, and when removed it boots fine. Maybe the problem is LUA related? As it is the only mod that uses Lua that I currently have. Any other mod works fine, it just weird that it crashes on startup instead of ingame.


#348

Are you having this joystick issue in all of the new builds (since I made the mainline PR) and not having this issue in the Google Play build on the same device? If so, to me that sounds like an SDL Android input bug, since none of the joystick input code has changed since the Google Play version, but I did update SDL from 2.0.5 to 2.0.8 as part of the mainline PR in the hopes it would resolve our software renderer issues, but it doesn’t seem to have fixed them and may have also introduced this bug on certain devices only (like yours). We could look at downgrading back to SDL2.0.5 and sticking with that instead. I’ll also make a note to sift though SDL bug reports and see if anyone else has patched it or experienced the same issue.

Could I also ask what Android device and version you’re using?


#349

Maybe you can try this version.https://drive.google.com/file/d/1GtGVfX1yct_LLIKWNxNXJ0pEvERLAwi3/view?usp=drivesdk
This used an updated version of SDL.


#350

Hmm i did not notice that joystick bug, was using otg with keyboard. Only problem with me was some survivor first aid errors showing. Some npc spawns with it.


#351

Which mod version did you use? Latest mod version from github doesn’t work on PC either - see https://github.com/Regularitee/KawaiiMaidMod/issues/1.


#352

Im using a Galaxy J3 Eclipse and version 32345, though this problem has been present in every release, except for the Google Play Store version.


#353

Looks like this version fixed the problem, everything works perfectly now. Thanks guys!


#354

Ah very interesting! @EhNuhc, do you recall which SDL version this was compiled against? Was it latest development tip from SDL’s Mercurial perhaps? If so then good to know, we should probably update the official dependency to this version to avoid that bug.


#355

@a1studmuffin,forked latest SDL from https://hg.libsdl.org/SDL/rev/b504b29c3831 with little hacked/modified.It might fix joystick’s bug,but rendering was still work terrible.


#356

You have officially gotten me addicted to this game, haven’t even tried it on PC because I’ve been to busy using the Android version.


#357

I used the latest version of the mod, I can confirm the mod worked on PC and older version of the Android one. I knew about the commented line. The game doesn’t boot when the mod is located in the mod folder. When I remove the mod it boots fine. There is no debugger errors, just the game refuses to start, i can’t even see the Main menu before it crashes.


#358

I’m crashing on a Galaxy J3 2016, any suggestions?


#359

Nevermind, just had to turn off software rendering


#360

@JebiBones,Maybe you can install and play this version.It used a modified lua of 5.3.5.(fixed your problem?report bug @ me)cataclysmdda-0.C-32499-g060387c3de-release-signed.apk


#361

So, did you fix comment on line 787?

Also what’s your Cataclysm version?


#362

Alright, I tried the apk and it didnt work. However, I found that there was a duplicate file inside the mod folder (somehow) and when I deleted, the game started up fine, so It seems it was an error on my part. Sorry for causing trouble.


#363

Yes, I did fix the comment on line 787 and the cataclysm version is the lastest you provided. Anyways, I found the problem, there was a duplicate file on the mod folder and when I deleted it, it just booted fine. Sorry for causing trouble.