Why do the mainline mods give me "id" instead of "ident"?

I’m using the launcher, and for reasons (I think I was worried about conflicts with other mods) I uninstalled all the mods it came with. Now I’ve tried to reinstall all the mainline mods (which maybe are different from the mods that the launcher comes with?) by downloading the normal game and copying them over. I also have Goat’s community mod compilation, which was previously working. Now, though, I got two different “requested ident but found id” errors from two different mods that prevented me from launching the game. I’ve gotten these before in other mods, but I figured the mainline mods wouldn’t give errors like this. I’m pretty sure I got rid of any duplicates, so I don’t think it’s that. I downloaded from the github, could that be the issue?
Edit: whoops, messed up title

Ok, it seems like the problem might have been that I just downloaded the source, rather than an actual release. I’m able to launch the game now, anyway.

Looks like you’ve fixed it… for the future, it would us help to know:

  • The build version of the game you’re trying to start.
  • The complete message you’ve got.
  • The name of the “two different mods” that are causing the problem.

Otherwise it’s really hard to offer a solution.

You are using mods from a different game version. Backup your config and save folder and reinstall game.

Sorry-I think the mods were aftershock (not the community version, I think) and blazemod. I was using 0.E-2, but I think the problem was that I initially downloaded the source of cdda straight from Github, rather than the actual release. Doing the latter seems to have fixed it.