Mod Problems After Update (Using Launcher)

I haven’t updated my game since last year, decided to do so today. I update fine, download the mods and transfer whatever I want from the mod folder over to the version I am going to be playing now. But, my game does not recognize any of the mods. I have a good 30 mods installed that aren’t vanilla, but when I go to create a new world, it only recognizes Jury-Rigged Robots, and like Magiclysm, most of my other mods do not load or appear on the list at all. AND my Dead People tileset that is in the gfx folder does not appear under the tilesets tab. Is this a game problem or is there something I need to fix? It is like it is not recognizing that 90% of my mods in the mods folder even exist. Despite them showing up in the launcher mod list, and me being able to see them in the folder myself.

1 Like

DeadPeople tileset was phased out of mainline due to copyright shenaniganery but is still maintained (I believe) and can be downloaded from the source and placed into gfx. I don’t know what mods you run so I can offer no insight on that.

1 Like

It is not that, I have a copy of deadpeople. The problem is the game does not recognize it even exists in the gfx folder. It only recognizes like 2 mods out of the many I put in the mods folder when building a new world. Is this a problem you have seen before? The “previous version” folder can run it fine and recognize the files in its folders. Th mods themselves don’t matter, since mods like “foldable parts” are not recognized, but Magiclysm is. I don’t get why only a few mods are recognized in the mod list.

Beats me. Whenever I encounter significant problems I go scorched-earth, baleete everything and start from the ground up.

1 Like

A lot of mods have been made obsolete, as far as I know. Not sure how the launcher handles this and/or why some of them are working, but it might be related to that (although it shouldn’t be a problem if you downloaded them from an extern source or moved them from your old game folder).
Maybe double check if the mods you try to run got a line “obsolete=true” in their according modinfo.json file and delete that line if that’s the case.

Sadly, I have no idea what’s wrong with the tileset.

1 Like

I have gone scorched Earth. New installs of cdda cannot even find the mods I install from the launcher or online.

1 Like

They have no such line. They are either downloaded from the launcher or sites, and even then, if I download say 12 mods from the launcher, only 2 or so will even show up in game.

This is the mods that show up. Out of the 115 mods (added/vanilla) only very few show up. Each other mod tab is barren too. This is a complete reinstall too.

Edit: Since it is not the first complete reinstall I have done, I don’t know why the game is doing this. It isn’t me is it? I haven’t done anything different than when I normally update. I have tried this with the last many update versions. It isn’t working for me. This mod list was full for me before, now it doesn’t recognize anything.

As Valase mentioned above, this sounds EXACTLY, like the obsolete mods change that occurred recently. Watch this video and follow the directions:

1 Like

Alright seeing the video I did it, and now it works. I didn’t get it at first, but now I just feel dumb. And hey it’s you Vormithrax! Thank you though, and the person above who already told me but I was too dumb to get it right the first time.

Thank you man this was the answer, I just for some reason didn’t do it right the first time.

1 Like

No problem, glad you could fix it. Good luck survivor :wink: .
Were you able to fix the problem with the Dead People tileset too?

Thanks for that Vomithrax, I really appreciate all your videos by the way.

I traced back the original thread to and it’s quite a draconian response. Personally I never play DDA without the now-missing “prevent zombie revivification” because like they say online “ain’t nobody got time for that”.

But as one of the developers on the thread said “If you don’t follow development, you don’t get a say in development”.

Maybe I’ll revisit CDDA in 6 months or so to see if things have normalized a bit.

1 Like

Got it working but I have no idea how I did, but that seems to be the way things go when messing with settings. Thanks for asking!


I’ve been trying to get into the game again but as it stands, I play with a lot of mods, many of which I deem pretty much essential in my enjoyment of the game.

Pretty sad to see most on the mod list, even the relatively harmless ones like “prevent zombie revivification” or “no explosive zombies” removed. I hope someone can either revert or update the mods in question, as i’m looking at the github thread and the logic behind it is that “You’re not playing the game as intended, so i’m removing the freedom for you to use these mods that I’ve deemed obsolete.”

Though what i’ve read is that they’re mainlining some mods that I use already, like tanks, more buildings, etc. If anyone can give me a list of what they’ll merge and what they won’t, it’ll be greatly appreciated. This way I can add-in the mods on my own.

I dunno, coming in after a few months of inactivity only to find most mods obsolete and the only way to get them to work is to fix them manually.
I’ve also been having issues with the ascension mod, as the game refuses to create a new world with it in, but my guess is that the mod is old and conflicts with whatever core stuff is in the vanilla game.

Is that these mods are old, unmaintained, and falling apart, and nobody who cares about them has stepped forward and offered to fix them and keep them working.


The logic behind the “Prevent Zombie Revivication” mod being obsoleted is that it’s unmaintained? It’s zero maintanence. Literally just sets a single flag to false for a single species, it doesn’t even have any files beyond its modinfo.json.
I can see the death of some other mods being vaguely reasonable, as they actually require effort to maintain, but that one in particular baffles me.

Well, it’s not just magically working on it’s own. Theres a part to it that has to be hardcoded and if that part is unmaintained/unchecked, then… well… the mod is made obsolete, I guess.

Right. Foolish of me to make statements like that.

Here’s the comment in question.

I’m mostly arguing against making blacklists obsolete. The others are mods that should be merged in the first place.

Personally, I hate reviving zombies. After my experiences back when I played 0.A, I’ve turned the reviving zombies off and never looked back.
Even so, there was a push to merge this mod with classic zombies. Not a fan of the choice.

I do agree with merging mods that should be mainlined, I do agree with removing mods that just don’t work, or haven’t had anyone work on them for a long, long time.

I don’t agree with removing blacklists or player-preferred balancing.

If you don’t like explosive zombies? Don’t play with them. Don’t like the complicated nutritional system and want to play like it was in older versions? Your choice.
Feel that autodocs should work 100% of the time? Done.

These mods are debatable, as it’s player preference but I doubt that it’ll be a Herculean task to tune them up when needed.

1 Like