Too heavy for it's engine?


#1

So I’ve been suping up a vehicle, only I have a problem. Too heavy for it’s engines. I was originally using a V6 engine. So I then switched up to the V12 which I was told was better, no dice. In trying to find something I heard it MIGHT be a glitch? But I’m not going to put it past myself that this is likely human error on my part. Anyway, here’s the layout, please help me if you can.

https://imgur.com/a/aKzNqYz


#2

I don’t see anything wrong with it. Someone told me that they drank fuel from tanks top to bottom, though, so I wonder if that being a diesel tank means the engine’s not getting fuel.

I’ve gotten the ‘is too heavy for its engine’ message upon running out of gas. But that’s really all I can figure, and it’s just something someone told me so I don’t even know if that’s right.


#3

Just tried removing the diesel tank. No dice. Thanks for the suggestion though.


#4

Your offroad coefficient is pretty low, maybe you need bigger/more wheels?


#6

That engine is pretty far in the back, it might have shifted the center of mass outside the wheelbase.


#7

Turn on debug mode (need to bind in keybinds first) then examine the vehicle with debug mode on to see its center of mass and pivot.


#8


Alright, I moved the engine there, I don’t know if that’s what you wanted me to do, but it’s what I tried. Didn’t work. Anyway, this is where the center of mass and pivot is. What do I do now?


#9

Is ‘too heavy for its mass’ a system message? Never recieved one. And a V6 should be okay for a 6.7 ton vehicle. So it’s probably not the engine type that’s causing the problem.

Have you considered checking the wheels as @darktoes suggested?


#10


Using 24" wheels, six of them now, made blue lines to show where they all are, but more wheels didn’t help, at least not the additional 2. And I relocated the engine back to the front, indicated by the red circle.


#11

Did you try to create an amphibious vehicle?


#12

No that isn’t what I was trying to do, should I?


#13

No, because it’s disabled and broken. If you install floaters, it sets your traction to zero causing that error message.


#14

I didn’t install any floaters to it.


#15

I don’t suppose the engine is disabled in the vehicle controls?


#16


Is that how it’s supposed to look? Does that mean it’s toggled on? I can’t figure out which button toggles it off and on anyway, nothing seems to happen.


#17

I think that means it’s on, and I’m not sure you can turn off your last engine, so that might be why you can’t turn it off.


#18

Huh, that’s unfortunate. Anyone else have an idea why this isn’t working?


#19

That’s indicated in the vehicle screen in the topmost row.
V12 - Use (yes)

@Westafrica no ideas. But just in case, could you list the mods you’re using? And have you driven any other cars? Have you tried other engine types?


#20

I tried a V6 engine before this, no avail. Other cars work. Notably, this happened once while I was working on an RV, but I just assumed the RV was broken.

Here’s my mods.
My%20mods


#21

Best bet would be to make your save available to others could troubleshoot it and get back to you with a solution