Stupid question re mods: which one is killing me?

I started a game with a possibly inadvisable amount of mods in order to make things a bit fresh. I’m not sure why, but now I bleed to death every time I try to use an autodoc. Even with less than 10% failure chance. I even added ‘safe autodocs’ bringing the failure chance down to 0, and it still kills me. I have to assume this is due to my modding choices, but is there anything I can do about it?

[
“dda”,
“no_npc_food”,
“aftershock”,
“crt_expansion”,
“magiclysm”,
“ArmUpPAUtil”,
“ArmUpSurvEx”,
“bioco”,
“CIVILIANPOWAAA”,
“adv_gear”,
“arsenal_breach”,
“SD_Magcrafting”,
“ExArch”,
“antifunguskit”,
“Medieval_Mod_Reborn”,
“metal_elemental”,
“demon_spider_a”,
“More_Armors”,
“Pix’s Shit”,
“pressure_weapon”,
“offal-sausage”,
“rf_food_keeper”,
“VermilionMod”,
“mo_monsters”,
“convenientconstructions”,
“more_survivor_stuff”,
“MMA”,
“basement_extension”,
“oa_early_game_mutations_mod”,
“blazemod”,
“BayonetCharge!”,
“beamswordmod”,
“sarcophagi_access”,
“No_Bloated_Zombies”,
“temp_effects_reduced”,
“StatsThroughSkills”,
“stats_through_kills”,
“speedydex”,
“more_char_creation”,
“Tanks”,
“battletech”,
“safeautodoc”

Can you please tell me the version (stable/experimental + version number) you play and, since you already on it, if you use the launcher or not, the operating system you playing on and if it’s the tiles or curses version?
I’ll test it when I get the time for it and nobody else already answered your question until then.

Even more information, although opitional, could also be helpful (as in: what bionic are you trying to install, what are the relevant stats and profession of your character (even though the safe autodoc mod is installed, there might be some collision), is there an NPC nearby, in what location do you use the autodoc (Lab/Hospital/…), is there a Nursebot nearby, …).

PS: Did you try to start a new world within the same game version without all these mods active, and if the answer’s yes, does your character still bleed out?

Don’t waste too much time on it on my account, I think I probably brought this on myself.

I’m on experimental 0.D-12741-g516ef1, tiles version, no launcher, on Windows 7 64-bit.

I’ve tried several different situations via savescumming. Several different biotics, with and without the nursebot present, in an underground lab and the upper floor of a doctor’s office. Skills are all around 7.
Originally I had no mods added after world creation. I then added Safe Autodocs to try that.

I haven’t spent the time to make a new character and get them to where they can obtain and install a CBM. I could look up spawn commands but haven’t done so yet.

Ah’, don’t worry. Who needs sleep anyways? Just don’t tell to future me that I’ve said that. And yes, you totally did :wink:

Well, I’ve got some good news and bad news (after about 3 hours of mod installing, fixing and testing). However, I can’t really tell which is which.
The base game has no problems to install CBMs. Also, I was able to replicate the bug using your mods list.
So, there’s a chance that I can identify - and maybe even fix - the mod that’s causing this. Probably not today, though.

1 Like

Thank you for that: BioCo is the one that (intentionally) touches bionics of course.

1 Like

Indeed. I first thought it might be the Convenient Constructions mod causing this, since it allows to move auto docs (and maybe messes up something behind the scenes), but no, it was my second guess; BioCo.
I’ll take a look to see if I’m able to fix that.

PS: I need sleep. Past me is stupid.

Found it & fixed it!

Go to data/mods/BioCo-master*/furniture/ and open the furniture_override.json file with a text editor of your choice.
*or whatever you named your BioCo mod folder…
Set the “flags” of the “f_autodoc” to

“flags”: [ “TRANSPARENT”, “AUTODOC” ],

and you’re good.

I think @Poragon stopped maintaining the mod, so I guess it’s up to roaringjohn to fix it (I’m not forking this only for one pull request - yeah, I’m lazy).

Edit: …Or @TheGoatgod, whoever now is in charge of that mod.

1 Like

thank you @valase I have updated in my mod compilation

1 Like

Woo, time to fire up the nuclear reactor and turn on the autoclave. I’ll raise a glass of plutonium slurry in your honor!