Some recent weirdness

wooden counters. i tried to move one to my crafting room but didnt have the strength so i thought i’d reassemble it there but it wasn’t possible

I take it back, it isn’t sensory dulling that is broke. Even with anesthetic kits in my inventory it still gives the “don’t have enough anesthetic for this operation”

Another thing I’ve noticed is inconsistant lighting while underground, I think the game is still taking into account the time of day to determine the amount of nightsight you have even when it shouldn’t be.
This is with 9 perception with 10 eye encumbrance and no traits just after dawn:
This is the same character/stats/traits/gear in the same place just after dusk:

Counters should definitely drop a panel, I’ll go fix it.

How much did u have in ur inventory and what CBM were you trying to install ?

The other thing with the deadened trait is a bug, but this one might be ibtended behaviour

Not sure, the first time I think I was full up but the second time I think I only had my normal stuff and a power storage mk II and a couple of others. I could be wrong, it wasn’t something I was expecting to cause a problem so I didn’t take note.
I tried a few different things the first time, hydrolic muscles, power storage mark II, chonometer etc The second time with the kit I only tried the power storage Mk II
What was the intended behaviour you mention? The message says “You you don’t have enough anesthetic…”, nothing about space etc, that would also be a bug I’d assume even if the rest was intended?

Now anesthetic charge have a volume of 1ml insteaf of 1L, each operation takes a different amount of anesthetic, If you have less than that amount you can’t do the operation.
However pain removing trait should make you bypass that check so there’s at least one bug here.

The kit was fully charged, it was the one outside the door to the autodoc.

edit: I misunderstood what you ment, I thought you were asking how much volume I was carrying :stuck_out_tongue:

Probably a few missing/misplaced checks in the code, shouldn’t be too hard to fix. It’s amazing how I keep missing those bugs when messing with anesthetic though U_U

1 Like

Spotted this too

“more then forever” I… I’m not… What does that even mean?!

Just updated to latest build.
Status screen has a bug, tabbing across to different sections consistantly crashes the game, you can still shift tab back though the various sections though.

Edit: You can ignore it, but any other option crashes the game.

Long after the heat death of the universe, when all living creatures are dead, when time loses its meaning, when all is consumed by entropy and the void embraces all things, the shelled almonds shall remain, perfect, unchanging, eternal.


I’m sure I’ve heard something like that somewhere before.

Another bit of weirdness:

I’ve got the expanded digestive system so that will have some effects but something still seems off about this :stuck_out_tongue:

Triffid expansion was incredibly fast in the game I just tried…found some random triffid, and within a couple in game hours it had expanded several 5 map tiles and surrounded my evacuee start

The Battery CBM requires you to go directly into the inventory menu and manually use the “Eat” command, sort of like how you used to be able to (can still??) with storage batteries. That was with a medium battery, I’ll see what it’s like with other battery types.

Edit: same with all battery types as far as I can tell, not had chance to test with a storage battery yet so dunno if it’s still the same with them but it’s not really an issue when you have disposable batteries of 2500 upward and rechargables of 1250 upward.

By your post, im assuming that the rechargables batteries dont dissapear, am i wrong?

Nope, you just drain them until you are full/they are drained. You are left with a empty battery after.