Seasons seem really bugged

Really weird stuff, seasons are all over the place. 2 day difference in settings on the top two gives a 2 season difference and the bottom one shows what are supposed to be day one spawns with normal evolution rate. This is literally me starting and running straight outside for a screenshot.

Edit: I just did another test and all food that can rot is also rotten, Intial day doesn’t seem to work as intended from what I can see :confounded:

try making the season length the highest or lowest (if 0 is allowed) it allows you to set it, it might be just the combination of season length and starting day landing you in a different season than you were aiming for.

december 21st (2019 winter start via google) would be day 355 for reference.

not sure, but that might very well be the problem.

The first two examples are the lowest, 14 days. The first world is a copy of the seconds settings but just with the start day moved back 2 days but it gives you a 30 day difference.

yeah, just spent a while messing around with it out of curiosity and well… i can’t get any joy landing in a particular season either, i tried day 355 with 91 day seasons, with 90 days seasons, observed it was day 86 of the current season and figured to try day 359 with 91 and 90 as well, then 360 with 91 and 90 as well.

none of them started in winter.

i also just now double checked that it wasn’t wanting us to just choose 1 through 4 to set the season with the day, doesn’t appear to be the case unless the setting for spring is 4.

Well, I just got it to start as “winter” on 14 day seasons with day 4 start, snow on the ground etc but it still had spring temperatures.
It seems really bugged :disappointed:

github issue created:

1 Like

Ah, nice one. Should of thought of that.

There are already issues that cover this. Here’s one:

well it definitely seem to be an issue with one of the mods somehow, i just created a test world with only core loaded 91 day seasons and day 356 and can reliably land myself in winter.

that makes no sense, i don’t think any of the mods i use should have any sort of changes or interactions with seasons at all.

That’s really weird, I run a bunch of mods too but I’m in the same boat, none of them should affect seasons.

yeah, i honestly don’t have the time to bother going through and removing one mod at a time to find out which is the culprit either, i’m leaving for a long weekend later today and this would take a while.

disregard what i said before, i had a lucky guess just now when i was removing expansion style mods on a hunch one by one, testing and then repeating and it appears bright nights is the culprit here, once i remove that mod i can set day 356 to start on and 91 day seasons and landed in winter twice in a row.

i never once landed in winter before with all of the above combinations, so i’m calling that close enough to decidedly proven.

Update your game - Bright Nights doesn’t exist anymore.
It’s been merged with and replaced by Aftershock.
Regardless, it shouldn’t have an effect on this.

I’ve never used Bright Nights :thinking:

Yeah, I think I fooled with Bright Nights once, but none of my current characters have it enabled, and I can tell you from experience that the code regarding seasons and weather is really screwy. Oh yeah, I even made a topic about it once.

Can someone familiar with this problem open mods/Aftershock/maps/afs_regional_map_settings.json
and delete the line "weather": { "base_temperature": 0.0 } (and remove the comma at the end of the previous line).

Then see if this problem persists?

I tried it, this was a day 319 start:

Still wrong season and evolution and (presumably) food rot are still advanced