Question: how to import a single map tile to a whole new map?

tl;dr I messed up my map generation settings but I’m too deep into this character’s story to give it up, how do I preserve him & his loot & cars on a new map?

Detail: I have spent about 30 hours on my current map. There’s one city nearby that I enjoyed exploring. My character’s currently recovering from a broken arm. He’s brought 4 vehicles home to strip into a megacar, has 2 pet rabbits, has a few chickens nearby for eggs, and has planted plenty of crops. The character’s accumulated about 4500 volume worth of loot.

I’m enjoying the character. But I’m not enjoying the map I generated, now that I’ve explored my nearby city. I wish I’d set the map parameters to include much larger cities and much less forest. The nearest city, beyond the one my character’s next to, would take almost 40 real-life minutes just to drive to. I normally prefer to have cities close together. In-game road maps confirm this.

Note: I’m not too attached to keeping the map tile or creatures or even the vehicles but keeping my character’s stuff would be super-helpful. If there’s a way to do it without having to somehow get 5,000 volume and who-knows-how-much-strength on my character & then import him to another map, though, that’d be amazing.

If i remember correctly, you could mark the corners of the overmap tile you wish to transfer with graffiti and then search for the phrase you wrote in your save file. The map files having names such as o.0.0 or o.0.1.
Once you found the overmap tile marked with your graffiti words you then move that file to your new world along with your character save file.

However i’ve never done this. You could probably find a previous topic discussing how to do this on the forum somewhere.

What do you mean by graffiti? Pardon my ignorance. I’ve transferred characters between saves before, and a vehicle once, but never a whole map tile.

He means writing on the ground or whatever. A unique phrase you can search for in the save’s map folders. That way you can identify the range of map files you need to copy over.

Well, I might have a suggestion then (make a backup first, in case something goes wrong!).
Probably the easiest way would be to bind the debug menu to a key of your choise, open the debug menu, go into [p]layer…->[M]utate, press slash, type in “debug”, press enter to confirm your search, go to “Debug Carrying Capacity”, press enter, escape, [g]ather everything up (you could also take the pets if you find/craft some pet carriers (or just spawn it in; debug menu->[s]pawning…->Spa[w]n an item or …->Spawn [m]onster when you arrived at the new map)), save, create new world and move your character to the new save.
Before you now drop everything, two warnings:

  1. If you have a lot of stuff and want to make use of the automated sorting using zones, make sure you do not drop more than 25 tiles worth of material on one spot! If there isn’t enough space for it on the tile you are dropping onto or the 24 tiles around it (2 tiles in all directions of your drop off point), it will simply void any additional item added on top.
  2. Again, if you have a lot of stuff but not that many high volume ones that it would overflow the 25 tile limit, still do not drop it all at once! Depending on your computer and the amount of items you have, you’d be stuck for a very long time, but only if you do it all at once (for the technical explanation why this happens see below). So drop your inventory in small portions of 100-1000 items at a time (try to find out which range works best for your computer). This does not apply for items which have their number written in round bracklets behind the item name. These can be dropped whole.

Now, after dropping everything, open the mutate menu in the debug menu and press enter again on your “Debug Carrying Capacity”.
If you spawned in some pet carrier and want to get rid of them… throw them into a fire, lava pit or run them over with your vehicle(after you released the animals, of course!).

The technical side on why dropping large amounts of items is slow: It is slow because the game “saves” a list of all objects you want to drop one by one (= not “3 screwdrivers”, but “screwdriver, screwdriver, screwdriver”), loads that list, takes the topmost object from that list, drops that, saves the whole list again, passes one turn and loads the list again. This means that if you drop (for example) 100 planks, it will do it relatively quickly (internally it will write/load “only” 5050 objects). But if you drop 4000 planks at once, it will start to lag (depending on your computer) noticeably (now it will write/load 8’002’000 objects). If you were to drop 40 times 100 planks, you now dropped the 4000 planks, but your computer only handeled 202’000 objects. That’s why it takes increasingly more time to drop a large amount of items at once, compared to multiple smaller batches adding up to the same amount.
The exeption of this rule/process are items counted like “ammo”, for example butchery refuse (159). Those items are not “unique” and therefore only listed once, even if you were to drop multiple of them at the same time. Thats why you can drop your scrap metal (12075) without an abnormally large delay…

If you really want to take your house and cars and everything with you, it gets a bit more… complicated. @Sehn_Knight did a great job at describing the way to do it.
If that’s to complicated but you still want to do it, send me a private message and I see what I can do (may take a week until I get to it, though).

No, no, that’s totally fine! That sounds like the simplest solution. In a way, this works out greatly. It’ll add in the pressure to find a new working vehicle and base. I just spent so long gathering up all of these random materials to explore the crafting system that it seemed like a shame to go through all of that RL time to gather it up again.

Also… turns out the map I’m on got a bit “FUN.” While exploring the seemingly-endless wilderness, at a random wheat farm, I found a random survivor blockade with one guy in it. I avoided him easily. But then the wheat farm itself was full of giant worms. And giant spiders.

But something was killing both the giant worms and the giant spiders. Something invisible. I accidentally hit it a few times with my car and a “Graboid” was trying to break in.

I spun around in circles repeatedly, trying to hunt down this strange, invisible, silent monster… and I don’t know if my character rammed it to death or not with the car, but it stopped appearing. And somehow the hostile survivor blockade’s still standing. But all the worms & spiders are gone, gone, gone…

What’s even spooker is that underground my character can hear lots of mi-go screeching, robots attacking, and some KABOOMs. There’s not a lab map tile anywhere near here, not within 40 map tiles at least. And the lab area’s quite condensed in ~5 map tiles from what I can tell, based on where the sounds are coming from.

It’s… proving to be intriguing. I do want to see if there’s a secret entrance anywhere nearby, but I’m also afraid that the mysterious invisible silent Graboid is still out there, waiting to kill my character. Not to mention whatever else may be out there. This random wheat farm’s surrounded by forest, and the insides of the grain silos didn’t have any secret entrances. The only other building nearby’s a cabin that AFAIK didn’t have any secret entrances in it.

So now, to scour the forest for a secret entrance or to take the safe play and avoid the risk of a graboid altogether…

It doesn’t help my character still has a broken arm.

Graboid are a worm type and “invisible” while burrowed underground.

More details (spoiler)

They are mainly attracted by noise and move only on diggable terrain (dirt, grass, …), so stay at least one tile away from diggable ground and you’re safe (at least… from them).

I think it’s possible that the lab can only be accessed by the subway. So, if the city nearby has a subway, maybe have a walk in the direction where you heared the noises… after you fixed the broken arm, of course.

…Your map now intrigues me :smiley:

Unless it had been fixed: press “A” in overmap and look for a forest tile of nonstandard color.

1 Like

The Graboid:

1 Like

Oh my. The nearest subway has to be… goodness, at least 80 map tiles away! I’ll have to count the exact number though. Hrm.

Anywho, I won’t be abandoning this map until this bit is explored at least. I’m curious what all’s been happening under this random farmhouse. It’s a shame we can’t dig downward AFAIK…

spooky! I’m glad my character didn’t decide to tempt fate and that he’d parked his car on pavement!

Uhm… Open construction menu, press right until you get to “Digging and Mining” and select “Dig downstairs”.
However, I never tried this, so it may be broken or doesn’t do what I think it does…
Also, not sure you actually want to bust through the roof into a room with possible zombies, manhacks and a turret inside…

But isn’t that FUN? FUN in the Dwarf Fortress sort of meaning anyway… :slight_smile:

Well, didn’t you just wrote that you(r character) avoided any kind of !FUN! by parking the car on pavement :stuck_out_tongue_winking_eye: ?

…Although the game doesn’t have catsplosions yet, they have chicksplosions, which is close enough… so… it’s slowly turning into DF anyway :face_with_hand_over_mouth: ?

Please keep me updated on your labventure. I’m curious on how it turns out.

Will do!

Also I dream of having chicksplosions. I found a few chickens :slight_smile: And I have a few rabbits in my lovely base atm as pets.

It’s been interesting so far.

So when my character adventured into a KNOWN lab (not the mystery one), I hoped he might find himself a map that’d detail where other labs were, and their entrances. But after entering the lab, only the first basement level was accessible; the only downward staircase was covered by 4 turrets, one in each corner of the room.

They shot my character a few times but his super-heavy armor (Chichin & Kevlar & samurai armor mostly!) kept him safe. Not safe enough to be bullet-immune but safe enough to walk out alive.

He tried to push fridges & bookcases around the place until he could get to the stairs without triggering the turrets. This unfortunately didn’t work; he made it 8 tiles into the room, far away from the stairs, before they opened fire. 2 bookcases were destroyed. So he gave up on this. Instead, he tried to pickaxe his way past the entire room, figuring that this might let him get beyond the room and potentially into another room that might have a downward staircase.

This was taking him awhile. He spent 3 days pickaxing and wasn’t halfway there. Even worse, an armchair couldn’t be pushed into his makeshift mine shaft, since furniture can’t be pushed across pits with planks on them. No signs of a new room yet. He then realized “Oh, I could mine DOWNWARD!” and thankfully had everything he needed except one long rope.

So he left the lab to return outside, looking for rope. He found some cars to craft a rope. But while doing so he stumbled upon a scavenger trading outpost besieged by a mi-go. He dispatched the mi-go with a survival machete, with the trader using a Glock.

A research institute was also nearby. For the heck of it, he ventured over there (it was nighttime after all). He explored its perimeter. The security guards & scientists seemed simple enough, but not the kevlar zombies. So he didn’t risk entering deep into the facility… until, of course, a kevlar zombie spotted him & charged. So he ran deeper into it. He went up 2 flights of stairs, managing to lose the kevlar zombie, and idly explored. Nothing much, he thought. Random scientific equipment. Only one item of interest - a contraption to somehow produce welding gas. But he looted the western half of the floor he was on anyway.

He took a different staircase downward. A maintenance staircase. Safer. One floor down seemed clear. The next floor too. Just a blob, which he dispatched. Buuut… while fighting the blob, a kevlar zombie overheard him. And a few others. It was a brutal struggle, his health going down by almost half, but he survived.

It turns out that, immediately next to the exit, there was ANOTHER LAB. His map mysteriously produced two map tiles labeled “Subway Station?” on them to the east. Not “Subway Station” but “Subway Station?” which was curious.

So he explored this mysterious lab stuck under the research institute. It was a curious endeavor. More to come.

I suppose I’ll have to move this thread over to the storytelling section soon. But suffice it to say my character isn’t likely to survive before I consider a map move anyway, if I ever do!

1 Like

That’s quite the story your character goes through!
You got quite the funny mapgen as it seems…

PS: I added two warnings to my answer at the top, in case your character survives 'til you move to a different map (or someone else wants to follow the instructions).
Basically the tl;dr of it: After you moved your character, don’t drop everything at one spot and also don’t do it all at once, as one will destroy your items and the other will destroy your computer.