Question - How do I disable flesh raptor?

Hi, Could someone please help me disable the flying raptor from the game, thanks. lol

Flying Raptors sounds like dinomod, so create a world without dinomod.

Flying Raptor seems not to be a part of the dino mod, at least a search didn’t show any results.
It also doesn’t seem like it’s part of TheGoatgod’s mod compilation.

@vogt156: Could you specify what you mean? What’s the exact name of the creature, if it is a creature?
Also, maybe the version you’re playing on, the operating system you’re using and active mods would help us to help you?

Sorry, its actually called a Flesh Raptor. Its on the latest experimental. When a pupating zombie (evo of crawling) explodes, it spawns a half dozen around you.

What… the…?!

I’ve expected some weird mod, but apparently they are in the main game. I guess, I should update again?

Anyway, there are two ways to get rid of them, one is by modding them (or better, the spawing of them) out and the oder way is to edit the file directly. Which suits you better depends on this: Do you update the game often (or let it update by the launcher if you’re using that) or do you stick with one version for a while and don’t mind editing it every time you update your game?

I’d like to stop them from spawning. I’m starting to think I just have to wait until they get balanced and the problem Im having is just a part of playing experimental… hm

You could go into your Cataclysm:DDA folder and open the file zed-winged.json, found in data/json/monsters, with any text editor and remove the small_raptor_spawn and big_raptor_spawn special attacks from the monsters in that file, but you would have to do this every time you update.

Let me quickly write up a mod…

Here it is… I tried to make it without overwriting the special_attacks, but I was unable to get it working, this at least works…:

  • Open your Cataclysm:DDA folder and enter the data/mods folder.
  • Create a new folder, name it “noraptor” (you could name it however you want, but it’s a good practice to label it clearly).
  • Create a text file called modinfo.json in the newly created folder.
    • Make sure it doesn’t save it as “modinfo.json.txt”. If you’re not sure, you can go into any other mod folder and copy the modinfo file from there and paste that file in your folder. Just remember to remove that file’s content.
  • Copy-paste the following text into that file and save it:
[
  {
    "type": "MOD_INFO",
    "id": "No_Raptors",
    "name": "Disable Raptors",
    "authors": [ "Valase" ],
    "description": "Disables the spawning of flesh-raptors.",
    "category": "monster_exclude",
    "dependencies": [ "dda" ]
  },
  {
    "id": "mon_zombie_crawler_pupa",
    "type": "MONSTER",
    "copy-from": "mon_zombie_crawler_pupa",
    "special_attacks": [ { "type": "bite", "cooldown": 3 } ]
  },
  {
    "id": "mon_zombie_pupa",
    "type": "MONSTER",
    "copy-from": "mon_zombie_pupa",
    "special_attacks": [ { "type": "bite", "cooldown": 3 } ]
  }
]
  • Now generate a new world and add this mod to it (you can find it under Blacklist, it’s called “Disable Raptors”).
    • If you want to have this in your current world, you can edit the mods.json in your world’s save folder and add the following id to the list: No_Raptors.

I can’t guarantee that it will still work as intended in the future, but it should get you what you’re looking for for now.
I need to get some sleep now, but if you run into any problems and no one else fixes them, I’ll be back in a few hours.

2 Likes

I just finished my session but I will try it in the morning. I don’t know why such a thing spawns on day 3.

they were rebalanced a few hours ago. the next build will have tweaked raptors.

Yeah, they’re a little savage currently. :smiley:

Survivable for a mid tier character, but only if you can take cover quickly and have a large supply of bandages - if you get caught in the open you’re dead. Extremely deadly to new survivors as there’s no real hope of escape once they pop and low melee skill makes them nearly un-hittable.

The only thing I really don’t like about them is the fact that they magically spawn around YOU when they burst, not the pupae thing. That’s kind of overtly unfair. They’re already quite fast enough to fly a few squares and catch you without the magic surround spawn.

Edit: Oh yeah, just had a pack of six of these little @#$%ers spawn inside my Humvee while I was still a good 20 tiles away from a pupae. That was totally not cool.

That is deffinetly a bug

Hah, reminds me of the old “swarm of bees” field that would happily phase through solid concrete to sting the player.

That actually sounds like a great addition to the game.

Do we know if the remote spawn bug was part of yesterday’s fix?

Because right now driving through a town in a vehicle is very close to suicidal, as every pupae you pass within range of is going to fill your car with a swarm of these things. While my character is solid in melee, that’s pushing my luck badly.

yes, it may have only been implied but that’s what i said in my earlier post.

1 Like

Thank you for that.

@Vastin Thanks for setting that up. Didnt know making a mod was that easy… Should of just read the guide.

It was Valase! That other, other, ‘V’ guy. :wink:

Besides fixing the spawning-around-the-player part, the bug also fixed the bit where they were spawning at game start, they’re supposed to be an evolution.

I’ve fought a couple of pupating zombies and none of them have ever popped out anything. What’s this about them exploding? I haven’t seen that before.

I think after they got fixed Erk made it so that not all pupating zombies explode as to keep you on edge.