"Old Guard" second mission

So, I find the guy, get him to attack me, bash his face in, but the mission completion doesn’t trigger.

Is there something I’m missing here?

I’ve had the trouble with the first mission for both Old Guard and Free Merchants, actually. Go out and kill some doods, which I did, with dynamite. And it doesn’t proc as finished. Must they join the Sarcophagus quest as clutter in the missions list forever?

Dinamyte? I think it does not count as your kill, no?

Huh. I’d imagine the dynamite kill might not throw the mission flag as you probably didn’t get credit for the kill, but melee ought to work. Last I tried, shooting the informant after xe shot first (pissed xem off in convo) flipped the objective to complete.

Well, I blew their house to bits around them and shot them in the face in the rubble, pretty sure. I was assuming one of them might ahve ran away or something.

Not wanting to open a new thread for this because I have a similar issue:
(Spoilers ahead)
I was asked to do my second quest for the merchants and the quest giver was concerned about a trading caravan that should have arrived by now but didn’t. I should go check the last coordinates of their radio signal and so I did. Apparently they got killed by three bandits. One of them shot around with a browning BLR - at racoons and tuekeys until he was out of ammo. I killed all 3 of them with my longbow, one even tried to run and got an arrow through the back of his skull.
But what now? The mission marker still shows up on the caravan’s camp and I can’t tell the merchant what happened…

What version are you running? There was recently a bug where missions weren’t being saved when you saved and exited the game, so if you reentered nothing could complete the quest. I think it was fixed in a recent merge though.