Mod Updates (April 7th, 2022)

As of april 7th, I’ve grabbed the experimental android version, the gmc mod compilation, kenan2000 mod compilation and commenced the bug fix loop once again. I’ve processed 298 3rd party mods so far, roughly 250 are functional to the point of loading and not crashing out of the character creation screen.

Playtesting is upcoming now that I’ve got a functional base. I don’t plan on updating my cataclysm version for the moment unless something amazing is added or I encounter a game breaking bug that doesn’t come from a mod and/or can’t fix myself.

My criteria for shoving a mod into the broken folder are mutation problems, excessive gun troubles (missing magazines, undefined ammo types) and weird stuff I can’t narrow down the cause of better than ‘that mod’. I’ve been fixing things where I am able, which is suprisingly many places. I’m not addressing balance, because that’d be crazy.

I say all that, to say this: Bring me your favorite mods that broke. I may have already fixed it.

I plan to put things up on github eventually, but in the mean time I’m going to zip it up and make a link available that will always point to the most up to date version. After work. jeez, i’m late…bbl to finish this.
Feel free to discuss, request mods, share your own fixes…etc. Later.

Edit: Download my mods folder for the April 7th 2022 version of Cataclysm experimental.


Hi Malkeus

I would be very interested in your fixed mods mate if you would not mind sharing them

Thanks :slight_smile:

I’ve been slowly refining my build, playtesting has revealed that the load stopping errors are just the beginning of what’s wrong with our crop of mods.
As examples, mutant animals and Draco dog mod would only work as intended together if a 3rd mod combining their changes to a specific list was made. Cataclysm++ has gear that has ludicrous encumbrance values, a trait shared by several mods.

I don’t intend to right all the balance issues or fix typos or anything like that, just the game breaking stuff and conflicts. What I could release now is largely similar to the gmc compilation. I have a few more functional mods and a few less errors on load, but I achieved that by being pretty ruthless about cutting mods from the load order. Virtually no older mutation mods made it. My ‘too time consuming to fix folder’ has 40ish mods in it.

Once I’ve run through a few characters to find the subtle stuff I’ll revisit the idea of a zip of my mods folder. In the mean time, I have been trying to drop some fixes on gmc compilation repo, but the lack of a PC is slowing me down a lot there. The website interface is actually better than I remember, but still a pain.

If there’s a specific mod you can’t be without you can PM me n I’ll add it to the OP or something. Finding time and focus is challenging.

Yeah I can imagine how much work is is needed.
Any way if and when ya do release your fixed mods that would be awesome :slight_smile:

Thanks in advance


Oh there is one mod that I would like to see fixed because right now it currently crashes with it enabled


Any chance of getting “Ascension” mod (“Winning_DDA” is the directory name) to work? It’s a very old mod by now, so it’ll probably be a challenge, but it added a ton of endgame stuff (which is what CDDA is most lacking right now IMO) and it defined the game for me, there are a few other threads of people asking for it

Problem is it has a lot of dependencies:

  • the old blazemod (not Blaze Industries)
  • PK’s rebalancing which crashed my game when i tried to create a new world on 0.F3 (see details below)
  • arcana

So I tried getting it to work on 0.F3 - basically what I did was just install the most up to date versions of Ascension and it’s dependencies, some of them are fairly outdated as you can see above. It did not work, obviously. Trying to narrow down what went wrong to help you out

  • Arcana is up to date still so i dont anticipate it being an issue
  • Blazemod is pretty old, i used the most recent version of blazemod from goat’s community mod pack (which was in the “legacy mods” folder…) and goat’s modpack is, as far as i know, only working on 0.E not 0.F… so Blazemod might be the hardest one to get to work
  • PK’s Rebalancing is the one that crashed for me when i tried worldgen. It threw a bunch of errors about armor like this:

    After pressing I to ignore those armor warnings, This is the message it showed me right before it exited out of worldgen:

I get that you probably arent up for trying to get such an old mod to work but figured i’d pass on what i learned from my failed experiment in case you want to try. I think a lot of people would want to play it if it loaded, myself included.

I don’t think that mod was in my downloads, I’ll test it out. I don’t know anything about mapgen but sometimes my copy pasta skills synergize with my search skills and the fix turns out to be simple. Same thing with mutations.

I recognize that first error on pkrebalance, they look to be formatting errors, could just need some entries shuffling and bracket counting. Pita on a mod that adds a lot of content… I haven’t even tried pkrebalance so I didn’t realize it was broken even. Does pk have a separate stable version floating around? Something to look into.

I’ve been working on 0.F experimental from early april, so most likely nothing I fixed would be helpful on the stable. If 0.G is dropping soon, I will probably update to that and use it for a base.

have you considered putting the whole repository of updated mods available? i know theres Kenans repo for CDDA and Goats community mod compilation repo, but other than that idk any other sources of updated CDDA mods. I made a pull request for some updates to Artyoms and Locked and loaded on Goats, but if theres other properly updated mods (IE they use vanilla features where it makes sense, with length, barrel volume, speedloaders, etc), id love to have em

Uploading my whole mod folder now would just introduce more confusion. Picking a repo to push PRs on is good, I’ve chosen GMC since the prs actually get merged there. But I’m operating on a tablet and everything is a giant Bastard of pain when you operate github through the website. If someone knows a more convenient way to use the site on an android I’d be a lot more inclined to make PRs. As it is I keep having issues when I try to push multiple PRs without waiting for the first one to get merged so I can delete the old fork and make new. I’m certain it’s operator failure, but I’ve not often needed to push multiple PRs to github and never via the web interface.
Any advice is appreciated.

Got to admit I am looking forward to your upload if and when you do.

A lot of the mods these days dont work :frowning:

I always use latest exp verions I update pretty much as soon as ones out

Hey folks, how’re things?

Just came on to see how everyone is, and how the mods are going :slight_smile:

Does any scrap of my mod exist these days, or have people realised it’s true worth and deleted it yet? :stuck_out_tongue:

hi Malkeus
did you get around to releasing the updated mod pack?

we understand if you have not had a chance as real life gets in the way.

Thanks :slight_smile:

…I honestly remember zipping everything up and posting a link. Was it a dream? I haven’t had any time to work on things much since I posted this, so it will only be up to April. Still interested? I’ll make an alarm for after work to remind me to at least follow through on the OP.

Yeah I would still be interested if and when you get time.
Thanks :slight_smile:

I keep putting this off and it usually only occurs to me right before I fall asleep… Here’s my mods folder. Not data/mods, shouldn’t be any overlap with vanilla. There are lots of minor fixes and a couple compatibility mods. There are still a pile of errors but most everything should be able to load, I was moving the broken stuff elsewhere iirc. I think next time I do this I’ll pick a stable version as the base…

Download my mods folder for the April 7th 2022 version of Cataclysm experimental.

1 Like

To be clear, there can be 2 folders for mods in Cataclysm, Cataclysm/data/mods is the default where all the vanilla cata mods go during a fresh install and everyone has it. If you create a new folder in Cataclysm directory called mods you can put 3rd party mods there. It helps to keep things separated.

The download I made is my uncurated cataclysm\mods folder from April 7th, so it will have ALL the mods I could get working on that version. I haven’t had time to do more than glance at the boards, let alone clean up the archive. On the plus side, if you install the linked version of cata from April 7 you can most likely just drop the mods in and start playing with minimal setup.

If you wish to share your work I’d advise however you go about it be certain to inform people of which version it was tested on. The new version numbering format has made that a lot easier than before.

You can drop a link to an archive here or create a new post if you want. EDIT: I’ll put a link to anything you want to share in the OP.

I have been listening to murderunicorn talk about updates on YouTube, makes me wish I had the time to play…

Sorry for the delay. The site say my browser was outdated, I try waterfox and palemoon and finally can enter with librewolf.
About my “fix”, bad news. I test loading the mod alone just in case and throw errors. If I load 20 mods is fine or perhaps engine dont show the errors.
My actual JSON are very modified with constant storms, acid rain and a lot of stuff and work fine, but if a load some mods alone there are many errors, like “creature undefined” or “vehicle beyond map” stuff like that. Thanks for your generous offer but I recognize I dont have enough skill for upload mods and offer assistance if there are errors.
Still, if I can be of help I m here.

The undefined error sounds like your mod is dependent on another mod for a certain monster you are calling to spawn. Another possibility is a typo when calling its ID. These can be a pain to track down without an application that can search inside a large number of files at once, there are several free programs out there.

It seems you’re modifying mapgen and environmental data. I have avoided anything to do with mapgen specifically because it almost always breaks when I touch it. That stuff is confusing on every level.

I suggest making use of the Garage and Lab boards here, ask the community for assistance. Discord can be helpful too. Modding in cataclysm can be as easy as writing a text or as difficult as writing a thesis.

1 Like