Json error when creating new character

After updating to the latest experimental after a few months not playing, ran into this error when trying to create a new character in a newly generated world.

DEBUG : Error: Json error: :17569:31: Additional tiles defined, but ‘multitile’ is not true.

      "rotates": false,
      "multitile": false,
      "additional_tiles": [
                          ^

        {
          "id": "overlay_wielded_corner",

FUNCTION : bool main_menu::new_character_tab()
FILE : src/main_menu.cpp
LINE : 861

If I click through this with spacebar, it kicks me back to the main menu of the game.

Looks like something menu related got messed up in this build - or in the upgrade process. Any suggestions for fixing this?

Tried it in “last experimental”, it works fine - can’t reproduce.

Needs more information:

  • Exact version (either build version or version as shown on the title screen): “Last experimental” is not specific enough, as it updates about all 8 hours and we don’t know which one you have; there might also be different “last” ones, depending on where you downloaded it from (official website, GitHub, launcher…).
  • Mods that you’re running in that world.
  • What character (and starting location) you tried to create - or if it’s already crashing when you hit “New Game”.

According to the launcher it’s build 11281

Mods:

  • Dark Days Ahead
  • Disable NPC Needs
  • Bionic Professions

And it fails before I actually get to character creation. I hit the New Game -> Custom Character option, it loads in the mods/files, gets to the end of the finalize step, and then throws up the error and sends me back to the main menu.

additionally on startup I get other json errors like the below (about 6 similar errors) which might indicate the problem occurs earlier, though skipping these ones doesn’t seem to cause any immediate problems

DEBUG : (json-error)
Json error: :2:18: Failed to visit member fontblending in JsonObject

{
“fontblending”:
^
false,
“fontwidth”: 9,
“fontheight”: 18,

FUNCTION : void JsonObject::report_unvisited() const
FILE : src/json.cpp
LINE : 120

Hm… based on that information I suspect there’s a problem with the tileset. Do you use the default (UltiCa) one or any other?

I’m using MSX++DEAD_PEOPLE. Is that one no longer supported?

Edit: changed to UltiCa tileset and the issue seems to be resolved. Thanks for the assist

Glad I could help :smile: .

Officially, no, it’s no longer included in the game. I think the launcher still offers it though, but I’m not sure where it gets it from.
You might get that tileset to work again by downloading it directly from the author’s GitHub and manually installing it, as it might be a newer version than what the launcher offers (but it’s also possible that some recent change in the game or tileset broke something and it takes a while to fix it, so no guarantee on that).

should switch over to chibi ultica, wont be much of a drastic change in tilesets for you

and yeah you can directly download MSX’s tileset from their github if you really really want it.

1 Like

Somewhere around #11268 UnDeadPeople tileset was broken by a change to the CDDA code (basically, it was changed to make it more fussy about certain errors). UnDeadPeople is still being updated but not distributed with the CDDA package (dropped due to copyright issues on some of the tiles, IIRC).

When some kind and probably handsome person issued a bug report on SomeDeadGuy’s GitHub he fairly quickly fixed it for the main tileset but the extra tiles used with various mod packages are not yet finished.

You can, however, use the UndeadPeople (Legacy) version if you use those mods.

i mean there was also…

True, but the reason why it was removed from Cataclysm’s GitHub were - to my knowledge - the stated copyright violations.
To be honest, I shouldn’t have call him/her “the author”, as that’s technically not correct. A lot of people contributed, and someone included a copyrighted tile. Since it was deemed too laborious (maybe even impossible) to go through all the tiles and trace them back to their origin to verify that they were used with permission, the whole tileset was removed to protect the project itself (from what I understand).
SomeDeadGuy just took it over and maintains it on it’s own accord/risk.

But the reason isn’t really that important - and was discussed all over the forum and GitHub (and probably Reddit too), so one can search these places for more information about that - the important part is: It’s no longer supported.

1 Like

Has nothing to do with tileset removal.

SomeDeadGuy was already maintaining UndeadPeopleEdition (UPE). We asked repeatedly if he would make the effort to verify that all of his tiles were correctly licensed and he declined, so UPE was removed from the CleverRaven repo. Later, and separately, he got warned in Discord for spamming music links and responded by demanding he get banned from the project in general. His request was honored.

Parts of the ancestor tileset of UPE have been re-added to the repo as Chibi MSX or whatever it is called now, absent the clearly violating tiles, and with a commitment to remove any other tiles that turn out to be questionable in the future.

1 Like

Thank you for clarification.

So he already maintained it at that point, but he wasn’t the original author or if (nor the only one) if I recall correctly?

I know that some parts of it can also be found in the ChestHole tileset, but I’m not informed enough to know which one’s the “origin” - if ChestHole includes tiles from the UndeadPeople tileset or the other way around…

I believe the ancestry starts with some forgotten tileset, then Ranga, then Chesthole, then Mshock, then Mshock/Otto, then UPE, but I’m not 100% sure on all of that. Chesthole does predate UPE and both of them inherited from Ranga, and the sprites being used in violation of copyright were introduced in Ranga AFAIK.

1 Like