Hard crashes when moving or starting in Lab

Lately I have been getting this crash report very frequently. It happens both with mods and the basic vanilla as well. It seems to happen 100% of the time when trying to do a Lab start when starting at the bottom, and it happened here when i started on the surface and moved west. This also happened in another playthrough when i was driving to a new city.

This is getting so bad that I’m afraid to go anywhere or face constant crashes.


What does the log file say?

I’m not sure if each number is from previous crashes, or they are all from the same crash, so i am linking the whole crash file here.

Crash log

Thank you for the crash log.
That’s the stacktrace of one single crash, so it’s good that you’ve linked the whole file.

As for the cause of the crash, I’m not actually that great reading crash logs, but it seems to me that it has something to do with map generation and monster placement.
It might be related to this segmentation fault error an other player experienced and it’s most likely related to this one.


Some new information I’ve gathered on this bughunt (I’m going on a break for a bit, but I want to offer some information first). This will not be useful for players per se, but may help others in search for this bug (and players who want to avoid crashing).

Build: 0.E-b10707, Windows 64 Bit, tiles version.

As per information in this topic, I’ve tried to start in an unmodded world (NPC needs as per usual disabled), with the scenario “Challenge - Lab Patient”, profession “Prototype Cyborg”, no (changes to) stats/traits/skills, randomized description with the starting location set to “Bottom of a science lab”. It crashed on world build.

Conclusion; Labs do cause crashes reliably.

Same world, default settings (Evacuee, Survivor, no stats/traits/skills, randomized description, in a Shelter).
Revealed map, traveled in front of a lab entry - no crash, save.
Opened the door and walked in - it crashed as I’ve reached the half of the overmap tile.
It crashed again after reload when I moved past the half of the overmap tile next to the lab.
I’ve tried to map out which tiles I can step on and which not by carfully walking one overmap tile and saving the game. Sadly, it did not crash again and I was able to walk into the lab just fine.

After my break, I’m going to a new lab and try to document each overmap tile in reach of my reality bubble beforehand to find out which one causes (or has the potential to cause) the game to crash.

Since I still believe that the crash is caused by some monster or monster group, the other solution would be to just spawn in all possible lab monsters and see if it gets the game to crash.

Edit after break:
Some more testing shows that the new style labs (with subway connection, “microlabs”) can also crash. By a lucky accident I’ve discovered that even just the surface lab building (lab_stairs) on itself can cause a crash*. Spawning one in with the overmap editor and walking up to it crashed the game with the same stacktrace.
*While I belive that’s the case, it’s also possible that some random monster spawn in its vicinity to it caused the game to crash.

With this new information, I’ve went through all monsters from the group GROUP_LAB and manually spawned them in, which did not crash the game. One special case was the elite bio operator which generates with an additional starts variable. I’ve forced them to spawn by removing all other spawns from the group and it still did not crash.

My guess now is: It’s one of the randomly generated rooms taken from the palette (or, to be more precise, one of the monsters that come with such a room).
But to verify this I’ll have to code-dive a little bit, as this is, as far as I know, still hardcoded.

Well, I didn’t even need to code dive… It crashes reliably when closing in on a state park, too; on the two overmap tiles right next to the parking lot (state_park_0_0 & state_park_1_1), the only two of the four tiles that generate animals.
…I should get some sleep, but I want this done badly…


Well, I’m sure I’ve found the cause: mon_null. Whenever the game tries to create (or maybe assign a variable like is_animal to) a mon_null (the default for many, many monster groups), it crashes.
Not a solution to the crash, but at least I (and everyone here) now know what causes it…

Sadly, I’m too exhausted to code up a solution for that right now. But I’m sure someone will pick this up and fix it till tomorrow (or I’ll do it when I get up).


Awesome to see you found the problem so quickly. I tried the bad day start, and I got the same crash at start there as well. I added that crash log at the bottom of the one i posted in my second comment. Just in case you need more data.

Well, I’m awake, and apparently someone fixed this.
After this pull request is merged, that is…:

Got to love the fast work on this sort of thing. Any idea when the fix will make it into the next update?

Sadly, no. But since there are actually two suggested bugfixes (this is the other one, which was actually the first to post) and based on its significance, I presume one of them will make it into an update sometime today.

Looks like build 10713 will have this fix.


And the fix worked, just started a lab start at bottom and no crash. Major kudos to everyone!