Various Segfaults and other errors

so, I know the new version is still buggy, but, I’m getting segfault crashes when:

I try to pass through various parts of town(most notably a clothing store)

Go into other towns(of the two that I tried, it’s been 2-for-2, random roadside attractions did not cause a problem, similarly I have had no issue with random wilderness)

Try to use a soldering iron or makeshift arc welder to repair something

Other errors I’ve run into include:

the game refuses to recognize my Constructed rock forge as a viable forge when loaded up

As a note:
I am on Tiles-10704 version atm, the world has passed through the last couple updates.

1 Like

Considering the significance of recent changes, confirm these reproduce using a new world, at least for the segfault ones. There’s a lot of pieces churning under the hood, and world migration isn’t guaranteed to be viable.

1 Like

upon making a new world, and doing some immediately-out-the gate traveling, I ran into a segfault again… I may have been near another town, but I’m not sure as that part of the map wasn’t revealed.

Additionally, I got segfaults twice when trying to start a game in the freshly genned world

1 Like

Then you’ll definitely want to open an issue on the github, helps triage and elevate them to the right place. If the latest build is segfaulting reliably, they’ll probably get it dealt with right quick.

1 Like

Maybe you’ll find this post useful

I had another segfault crash while roaming around town in another fresh created world but that was totally random, I don’t know what could’ve trigger that one

Recent updates have removed the segfaulting while walking around, however, the segfaulting while using a soldering iron or makeshift arc welder to repair items(and, presumably a normal arc welder), persists. A pastebin of the crash log.

Also, the crafting menu still refuses to see a constructed Rock Forge as a valid charcoal forge.