[GMC] Goats Mod Compilation V 0.1.8 now with GMC.exe

Hey Goat, great modpack. Been playing for like 30 hours now on a map, and I think i fucked up.

Tried to add a soundpack, didn’t think it would be a problem mid game… But ever since i installed @'s soundpack it gives me a error when i launch, and the game crashes before I get to the log screen, giving an error for a “SIGSEGV: Segmentation fault”. Is there a way I can upload the crash.txt file? I cant figure it out

EDIT: Fixed it by deleting my options.txt file, I don’t know what in there made this problem but that fixed it.


It happened to me when i set up otopack but didnt delete the original soundpack i had to add the rest to - so i had that original soundpack with its identifier AND the new otopack. When the game encountered two of the same file it freaked and crashed, like it used to do with duplicate mods. (edited because I used the wrong word and it was bothering me)

1 Like

i was wondering if there is a mod for C:DDA that adds mythical demons like incubus or siren… something like that?

So I tried downloading your fixes to this compilation and I’m still getting this error:

DEBUG : Error: data/mods//Fallout-CDDA/martialarts.json: line 16:27: tried to start array, but found ‘{’, not ‘[’

    "description": "A solid stance allows you block more damage than normal and deliver better punches.\n\n+2 Bash damage, Blocked damge reduced by 50%% of Strength.",
    "unarmed_allowed": true,
    "flat_bonuses": [ {
                        "stat": "block", "scaling-stat": "str", "scale": 0.5 }, { "stat": "damage", "type": "bash", "scale": 2.5 } ]

FUNCTION : bool main_menu::new_character_tab()
FILE : src/main_menu.cpp
LINE : 781

And I don’t understand what that means or how to fix it.

Nice to have you back in cdda community :smiley: you’re definitely using an older version, it works perfectly fine for me on the latest experimental version - 10647


1 Like

Ah, right, of course. I’m using the stable version, that must be why. Thank you. :smiley:


Thank you so much for this mod compilation.
Just what I needed when I switched to this stable version


whats the stayherefornow? and im gonna give this a bash soon i want to have mods working so i can play a playthrough then ill work on my mod

What mods have you fixed? I’ll have a look through soon need to swap my 2070s back to my 1050ti ahhh

1 Like

More fixes for broken crash-causing old comments format



i havent done much on this for 2 weeks and keep wanting to get round to it, i translated few mods and little bits here and there updates from git. i think tomorrow ill have a bash at some more errors thank you kenan you are helping out alot, and everyone else who has contribuated to the project a big thank you :slight_smile:


I’m going to work more on this now, then expect bearly any updates after. As I concentrate on more factions and resident evil factions. I will be putting more time into this so expect every mod I hope to work for a pecific experimental version, I’ll update mods to include pockets as well. But after that nothing from my end till F. With how experimental is going atm i think this will be the right course of action.
I will upload a copy of the experimental version to the first post when I’m done. Enjoy the mods


Did you say…Resident Evil factions? That sounds appealing enough just on the surface.

1 Like

dont expect big things with factions but expect big factions :wink: i feel as there are code limitations atm but if they get expanded features i will be making factions more complex, or if i get round to leaning how to hardcode this game (this will be along time lol)

right now im going to make fixes if i means im working half the night to get this to work for Build #10707 then i will see how far before things brake and that will be the stable experimental realese of this no more till F. (although im hoping its just little fixes)

Hey, it’s all good! That you’re even attempting it is awesome in and of itself.

1 Like

Scratch that I feel asleep lol there are more update there now I’m doing it ASAP got building to do then this is getting my attention I can’t keep putting it off, I want to play with a dose of mods on lol

Not the same without most of them I feel


Turns out the mod compilation basicly doesnt work for current experimental ill try get back on top and get them all to post im gonna look now


i get this i will need to find out what mod doing it

edit- BB-guns , EW_Pack, FictonalWeapons, ManualBionicInstall, Modular_Turrets, More_Survival_Tools, NW_Pack, Safe_autodoc, Salvaged_Robots and tanks removed all due to segment fault until its fixed

Hey used only your mod pack stuff and enabled a bunch of things and for some reason it doesn’t get to character creation. it stops at a certain point giving an error about mr. stem cell and i can’t seem to figure out how to fix it since debug won’t tell me what is causing it only that info.

1 Like

Always show a screen or the exact wording of the error, Kisaki. Even if YOU can’t figure out whats wrong, others might be able to.
You could also start trying to disable mods slowly in order to figure out which one it is. If the issue persists even without mods, then its a bug of the newest experimental (if you’re playing experimental)