Getting a crash :(

i’m using this version of the game:

and i’m getting a crash with this message"
“Segmentation Fault
@box :/home/tC$”

this happened a couple of times when i tried to talk to an NPC, then when i got in close proximity to a certain NPC, and then when i was in the same town as that NPC, i figured that he/she must’ve been bugged so i took off on the road out of town. after a little while i found another NPC and was able to talk to her and i didn’t get a crash so i figured that the problem was solved.

however, a little while later i tried to check my issions and i got the crash again. now i’m thinking this may have to do with either taking too many missions, failing too many missions, or having lost a companion awhile back. for some reason i had reloaded the game and i forgot to wait for him to run up to me before starting up my flatbed truck, so he never rematerialized.


NPC’s are sortve unstable at the moment, you should stay away from them. (turn them off, they want your tasty beans and sardines anyways)

Wait a second, are you saying you’re using a version that is many many months old.
As far as I know that pre-installed one is for original Cataclysm, which hasn’t had an update in going on a year, and the developer no longer works on it.

nope, i’m pretty sure it’s DDA. i’ve played the original Cata and i’d know. it’s on an emulator and it’s supposed to be able to update, but i don’t know how.

Since that is several months old it may be pointing towards the old repository which is no longer being updated. If you can find where it is grabbing updates from then you may be able to point it towards the current repository. NPC have gotten quite a bit more stable since the repo was moved to the Clever Raven repository. That said, NPC are still not completely stable, and are liable to cause a massive crash and burn at any moment hehe. I think to update you type “./update” but that doesn’t help much unless you can change where it is pulling updates from.

Edit: Actually, what version does the game’s main menu say it is? That will probably help us track down the issue better.

i’ve got version 0.5-1112-g92daf7b

i tried typing ./update but it wouldn’t. i got an an error message:

error: unable to resolve reference ORIG_HEAD: No such file or directory
fatal: cannot lock the ref 'ORIG_HEAD
Recompile? (required if anything was downloaded) (y/n)

btw i’m using an '02 or '04 dell windows XP, using the emulator mentioned in my OP, so i know lliterally nothing about Linux.

Yea, that’s still pointing at DarklingWolf’s repository, meaning you’re a month and a half behind current development. Need to look into how that image is built so we can update it to point at the right place.