Game crashes on execution(0.D-8574)

My pc uses Windows 7, for clarification. A long time ago i used to play the game a lot and i loved it, had many characters and worlds and even sniffed around mods. Back then i would update the game regularly to the latest possible and use the launcher to play. Until then it was fine, i stopped playing for a while and recently i tried to go back. I downloaded 0.D-8574 and ran it without touching anything or any mods and everything goes smoothly until i try to create a character, at wich point the game crashes while loading the stuff before the creation screen. I tried to redownload it and it still doesn’t work, and i’m too afraid of making it worse to mess with the configs by myself, anyone can help me figure this out? Here’s the message that pops up for me: Screenshot_8

That’s a really old version you’re using. Try updating to latest experimental.

1 Like

I just downloaded the latest experiemental and now everything works just fine, thank you a lot!