Cannot load save


#1

After updating the game today my save no longer loads. Last time I updated to latest experimental was two days ago. restoring from a backup from 2 days ago did not enable me to reload the game.

When I select that world/character from the laod menu, it attempts to load it, gets to the “Verify” screen, shows all the values there being green, then exits the game, and exits the launcher shortly thereafter. Any idea what might be causing this? Creating a new world works fine, but I’d rather not restart if there’s a better solution.

mods are

[
  "dda",
  "no_npc_food",
  "filthy_morale",
  "novitamins",
  "crazy_cataclysm",
  "Tolerate_This",
  "makeshift",
  "Medieval_Stuff",
  "More_Survival_Tools",
  "mutant_npcs",
  "npc_traits",
  "boats",
  "deoxymod",
  "blazemod",
  "Tanks",
  "StatsThroughSkills"
]

#2

Same I even rolled BACK my version to when it worked now I can’t even load a NEW character into a NEW world… is weird.


#3

Sounds like you’ve got it worse than me. Creating a new world/character still works on mine. what mods are you using? Might help whoever knows the code well enough to investigate if they can see what mods are common between people it’s broken for.


#4

Did some testing, and all of my saves work if I go back to build 8192, so whatever changed occurred between builds 8192 and 8201.


#5

I rolled back to 8192 and since my previous save got deleted by the backup crashing I started a new world which worked then i created a character buuuut once I tried loading the world after creating the character it kept crashing till I hit random character then it actually loaded the world. I tried again with a custom character… spoilers it crashed and random kept crashing afterwords as well


#6

8195 added a bug with light sources that causes crashes, 8194 normally works.


#7

Sound advice, I can ACTUALLY play now thanks. :+1:


#8

8202 includes a fix that was just merged, and is in the process of compiling right now and should be done soon.


#9

Dammit Shard I was going to wait till it was out and tested to tell people, so I seemed all smart.