Do I get something wrong? Can't craft a welding rig

Just what it says. I can’t craft a welding rig even though all the prerequisites are met. It just says ‘You can’t do that!’
I’ve never seen brown color before. What does it even mean?

And yes, I have a makeshift welder with enough charges AND two additional ones without any charges or mods.

It’s because you’re using one of the makeshift welders as the tool to weld/craft it; hence why the “2 makeshift welders” is coloured brown.

No, I’m not. I have three welders in my inventory.

They could be modded (UPS, extra battery, etc).

The Game thinks you are. An ingredient is colored brown when it is also used as a tool to make the product, the typical case is making something that require hammering 1 and a rock and having only one rock.

No, they are not. I have one makeshift welder with a battery compartment mod that I’m using as a tool and two absolutely freshly crafted makeshift welders with no charges, no mods, no damage or anything.

That’s the point. The game thinks. Even though I do have all the needed things: one welder as a tool, two welders as ingridients.

Maybe one of them is too far ?

The game probably doesn’t distinguish items used as a tools and used as components.

They are all sitting right in my inventory.

Yeah, that seems to be the key. I guess it’s useless to ask someone to look into it?

There is probably existing issue on github already.

I believe this one:

Wield the welder that you intend to use and then drop the other two on the ground. The game processes item in your inventory and on the ground separately and should get around the bug.

Nope. Doesn’t work. Just doesn’t. I don’t know why.
Doing it in reverse doesn’t work either.

Well, that’s an old one. Kinda sad.

This might sound stupid, but maybe have two of the welders charged? I’d just debug more batteries in since it’s clearly a bug.

Nope. Still doesn’t work.
And I’ve accidentally used the new ‘hide recipe’ function and I can’t find the way to bring the recipes back, since the button is the same for showing and hiding, but you can’t select a recipe since it’s, well… hidden. Never mind, it’s done via the search.

I have no clue what this could be then.

I made a welding rig from makeshift welders recently and saw the brown colored entry. I don’t remember exactly what I did, but I got it to work.

Sry to revive, but i found a solution for me at least…

I had to unload my welder. After that it worked. Cant remember when they put these batteries in, and maybe its only a mod i use.

Hope this helps somebody :wink: