CDDA Game Launcher (Automatic updates and more!)

Hmm, just encountered this now…wth…
CDDA Game Launcher version: 1.3.16

OS: Windows-7-6.1.7601-SP1 (64-bit)

Type: <class ‘TypeError’>

Value: ‘<’ not supported between instances of ‘NoneType’ and ‘str’

Traceback:

File “cddagl\ui.py”, line 3078, in lb_http_finished

Worked fine last time i used it, nothing has changed, odd…

EDIT!!! - Downloaded the Launcher again, now its working fine, some of the changelog looks more refined…more information and some colors even, neat…assume its a new version?

Launcher somehow always crashes whenever I try to start it. Works fine without internet connection but as soon as it tries to update its changelogs it just crashes without any popups.

This is the event log of CDDA launcher crashing. Hope this helps.

Faulting application name: cdda-launcher (2).exe, version: 0.0.0.0, time stamp: 0x5b8e9a15
Faulting module name ntdll.dll, version: 10.0.17763.404, time stamp: 0xe1cce3af
Exception code: 0xc0000005
Fault offset: 0x00047b29
Faulting process ID: 0x315c
Faulting application start time: 0x01d500fee5e94097
Faulting application path: C:\Users\user\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\TempState\Downloads\cdda-launcher (2).exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll

The Launcher auto updater is still not working correctly. It attempts to check for updates as its grabbing the change logs and crashes at the update part (I think that is what the problem was reported as on its Github page). A new version of the Launcher is out, downloading that should any problems you are having with your current crashes, some UI updates and new mod suggestions have been added with the new update.

If you could post the log to Github page in the issues section (if you have not done so) I am sure rremyroy will look into it, though I found when having issues with the launcher that re-downloading the latest version generally helps

I am using the latest version. But it keeps crashing. I will definitely try to post it in github. Thank you.

it also populates the changelog instantly, nice!

New launcher is getting good, @remyroy! :smiley: Thanks for the continued work on it.

So, I have peculiar problem with 1.4 version of launcher. “Use Launcher folder as game folder” can’t be used, because launcher throws error when I try to do clean CDDA install. Only bypass I found so far is to install game into different folder and then move it to launcher folder. That allows option to work, and even allows updates. Sadly, updating works like in older versions, and thus move all .dll and .pyd files to older_version folder which bricks launcher itself. Will this be fixed or should I return to old version of launcher? As it is now, it’s completely unusable as portable launcher because it’s unable to remember CDDA folder and I have to set it manually every time.