Cataclysm DDA 0.4 Released

I award you the ‘Golden Monkey Wrench’ for outstanding contributions to furthering the folklore of barefoot mechanics (who are only peripherally related to shadetree mechanics).

Don’t think I didn’t notice what you did, coders.
Almost all the suggestions I made (I tried to suggest what seemed like simple fixes to annoying and legitimate problems) ended up getting implemented in one way or another into this release. It’s a joy of the open source development model that talking to the people that make it can get things changed for the better. The next time you bitch that something’s too hard, or you wish there was such and such an item, remember that the devs ARE listening to you for better or worse. Keep up the good work, guys.

I’m relatively positive that only child zombies are spawning with static spawns off, I’ve been to two separate cities, made tons of noise, and the only zombie related thing spawning is the children.

Have fun with influenza, everyone. New 0.4 release ensures that there’s more than just a zombie virus going around.

Also, finally decided to join this forum. Hopefully this roguelike becomes uberfamous and we get tons more people. 'Til then, hi all.

I’d love to know the answer to this as well because I’m stoked for the new version but I got a good thing going with my current dude.

Download into a separate folder instead of overwriting your current one. Play new one when you want, play old one when you want.

Short answer:
Saves aren’t compatible.

I’ve tried my 0.4Pre2 in 0.4Release save yeaterday, and it works perfect.

Hi, im having trouble launching the game in 0.4. Whenever i try, a message pops up saying

“This application has requested the Runtime to terminate it in an unusual way”

Any help?
(Sorry for bad english if any)

Pabloxi0, do be aware that loading a 0.3 save folder in 0.4 will crash the game - there were some fundamental changes in how save files are created. If you’re loading a 0.3 save folder, that might be causing issues, and unfortunately, it’s not very good at telling you what those issues are.

So, try deleting your save folder, and all templates?

if you are having a problem launching the game (not just loading a save) then I’d recommend deleting your whole cataclysm folder and redownloading, it took me 2-3 downloads for it to work for some reason.

Registered just to say that this game is amazing and I love it.

Health and wealth to the developers :slight_smile:

A related issue regarding artifacts was already in the issue tracker. Will add your remark as a comment.

I encountered a glitch with a Mansion, I was grabbing some pool balls and realized that when I cleared a portion of the table of it’s items, it disappeared. Looking at it still showed it as a pool table, but the graphic was just a floor. Does this happen to anyone else? It was only some parts of the table, seemed random which ones. Putting an item back on it reset the graphic, but only until it was removed again.

[font=calibri]Can’t sleep, might as well play more Zombie games. This one’s really cool, so here I am at 4am registering! I’m never this happy about insomnia! Well done![/font]

I play cata in my sleep. it’s really weird when I’m waking up and wondering where my spears are so I can catch breakfast.

I also catch myself wondering where I could find another engine to stick in my car and how many spikes I could put on the bumper.

Pthalocy, sleep deprivation can be like that. Just remember to sleep before you see buildings leaning into each other and the harsh click of your mind cocking it’s last defense. Props to anyone that gets the reference.

Nopkar, to answer your inquiries in order. Your neighbors car and all of them!

[font=calibri]Trust me, I know when I’m dreaming.

I must admit I do have a higher desire than usual to learn how to construct traps, but that was a thing long before this game made it interesting again. Mmm, spikes.[/font]

[quote=“Tchey, post:10, topic:726”]MOTD says “0.3”, is it only a small mistake, or i’ve D/L the wrong version ?
I’m on Linux and use the github deposit.

Thanks anyway, CataDDA is my favorite RL, by far ![/quote]

Same here. Any suggestions?

Maaaaybe the MOTD just didn’t get updated.

[quote=“rumpel, post:38, topic:726”][quote=“Tchey, post:10, topic:726”]MOTD says “0.3”, is it only a small mistake, or i’ve D/L the wrong version ?
I’m on Linux and use the github deposit.

Thanks anyway, CataDDA is my favorite RL, by far ![/quote]

Same here. Any suggestions?[/quote] Go make a new character and see if there is professions if there is than yes its 0.4 if there isnt then its 0.3. Also its like that for me too :P.