Canning pots and Braziers

I don’t have enough familiarity with the game yet to have a feel for what might be an issue or bug, or feature, or long-accepted-for-reasons thing, so I’ll just start chatting about it here for starters.
I love the crashed helecopter pilot start - done it a few times and had a few great deaths, however there was this one that was particularly unexpected.

I might tell the story somewhere, making a base in a rural house, cleared out a nearby camping site and private airport, had a couple of RV’s with good fuel etc, really lucked out, but to get to the point I had started to convert this house into the beginnings of a base, cleared out a nearby campsite and private airport and it was all good.

I was trying to get fresh water. Had a pond out the back and I built a brazier and a canning pot. Now - even though the canning pot has a boiling of 2, there was no option to boil water with it. Tried everything that would normally work but no option.
After googling, I discovered you could place the pot on the brazier and leave it. I did that, and the water did reach the ‘hot’ stage, but never boiled, or turned into clean water, just hot.
After tens of hours of trying these things, I am dangerously dehydrated so I drink a bit of the water to see… but it makes me ill and vomiting and that was the end of that.

Any ideas? From what I have googled, and from my previous experience, I should have been able to get clean water somehow with a fire, brazier, canning pot and water.

Did you use the crafting menu? There is a recipe for ‘Clean Water’. If it doesn’t let you craft clean water that way, does it then tell you what you are lacking to do it?

From memory, I tried that first - it said that something with at least boiling of 1 was missing.
I checked the can and it was showing as boiling 2

Here’s one of the weird quirks of Cataclysm Dark Days Ahead: You can’t (at least in the 0.F stable release) use the container filled with something in a crafting recipe, even if it uses whatever is in it. So you’ll need another container with (at least) boiling 1 (an opened alumin(i)um can would be enough to turn all the water in the pot into clean water).

As for boiling water when near a fire, I might remember that wrong, but I think this was implemented in an experimental version after 0.F… and I think it needs to be a raging fire.

Edit: I’ve checked, 0.F was released on the 3. July 2021, and the pull request for fire boiling nearby water (#51075) was merged on 28. August 2021, so it is indeed not in the game version you’re playing.

Thanks - understanding that quirk is definitely going to help me out.
Also, I mis-understood that this…

…merge would have made it in.

I am falling in love with this whole project :slight_smile:

edit ninjad by your edit…

1 Like

To be honest for a moment I thought so too, given that 0.F-3 was published in November… but then I remembered that usually only bugfixes make it into revisions, and checking the changelog confirmed that it wasn’t included… :smiley: