Android Version


#525

Ah, that’s a good suggestion. Are you able to turn on/off immersive mode yourself, or would you prefer if the app managed it for you, eg. through an “Immersive mode” option in the Android settings? I’m thinking the latter would make the most sense. When enabled, it would probably disable the two finger swipe up/down keyboard mappings and use them to show/hide the keyboard instead. It might be possible to allow swiping up from the bottom of the screen to reveal the keyboard, but I think this may cause issues as some Android implementations have their own system-wide actions for swiping in from screen edges.


#526

The best solution would be if the app could handle this itself.

I know when I was compiling my own version (before nightly builds of Android were a thing - an awesome thing by the way!) I made some changes so that firstly it would run in immersive mode and secondly I hijacked the two fingers swipe up and down gestures. I made it so that two fingers swipe down would hide the keyboard if it was showing and two finger swipe up would show the keyboard if only the quick shortcuts were showing. If only the quick shortcuts were showing a two finger swipe down would hide them. If nothing was showing then the first two finger swipe up would show the quick shortcuts then if you swiped up again the keyboard would show. (I also removed the toast when the quick shortcuts were hidden).

I found that this worked really well and allowed me to play in fullscreen without the navigation bar.

I’m not sure if there is anyway something like that can be integrated as it might not suit everyone? It was great for me because obviously screen real-estate is huge when you are talking about a screen that is. 5" - 6".

Also I think that (for me anyway) if fixes some slight issues when scaling fonts. My resolution is 1920px wide (without the navigation bar) but with the navigation bar it’s 1794px and with a font width of 8 it seems to scale perfectly at the full resolution of 1920px but not quite perfectly at 1794px.


#527

Ah yes, I remember playing with your build and seeing those changes, it was a cool idea actually - imho a better use of the two finger gestures than the current defaults (panning around the map). So perhaps the best solution is to add an “Immersive mode: true/false” setting to the Android settings. It defaults to “false” (preserving current behaviour), with a description along the lines of “Hide the navigation bar. Use two finger swipe up/down to toggle quick shortcuts and virtual keyboard.” When this setting is enabled, the “Two finger swipe up” and “Two finger swipe down” action mapping options are disabled to indicate they cannot be used in immersive mode. Sound okay?


So will the devs do update for android version (solved)
#528

That would be awesome! :):grinning:


#529

Aye bro so i got the newest version. February 26 and it keeps crashing everytime i open it. I even turned off software rendering and all that did was mess up the screen, it just showed a smaller version of the screen on top of the original which was frozen. Im using a 2gb ram alcatel 4 fierce


#530

I’ll have to test it on my snapdragon device, Mediatek CPUs very often have compatibility issues due to them not releasing source code for things and the newer android ports being a bit of a hack-job.

Anyway, game technically works.
Both software and hardware rendering for myself, BUT the renderer’s scaling is broken and it renders to a tiny window.

Apparently a fix is planned soon to fix all this, as it results in an issue on the PC version too.


#531

help?


#532

Known issue, I mentioned it on GitHub and there’s a fix in the pipeline, may take a little while to test and verify though.

Edit: More info here for anyone curious: https://github.com/CleverRaven/Cataclysm-DDA/issues/27843#issuecomment-466935886


#533

Same thing happened to me


#534

The same small window happened to me in the February 26 update when i turned off software rendering. If i kept it on it would only crash my game and everytime i tried getting back on it would just kick me out. I need help


#535

works great for me now using a device with a snapdragon 625 and 4gb RAM


#536

Ah brilliant, looks like it’s been fixed! Works fine for me too, tested 8551.


#537

I’m just here to say thank you for your hard work Stud! You rock! CDDA on Android is so good. It’s become my go to game to play on my phone. XD


#538

Any idea if/when you’ll be releasing an official 0.D release on the Play store?


#539

Never, it’ll be on F-Droid if anything


#540

I meant an official build from the Android developer. I see it was last updated Feb 21.


#541

The unofficial Google Play version is no longer active - just download the latest APK from the Jenkins build machine instead.

It can’t be updated anyway as the app id changed when we merged it into mainline. I’ve kept it alive as I don’t want to interfere with anyone who’s still playing on that older version.