0.C-12551-g88ee227 (Couple of Nasty Bugs)


after being away for a while, I decided to download the latest experimental and get back into the game. However, almost immediately, I have come across a couple of bugs that, while not game-breaking, are making it very difficult for me to play.

The first bug happens in the inventory, and it involves wielded items not being given a letter. This means that I have to manually move to the item with the arrow keys, and then press ENTER to do anything. This is fine until I need to place an item on a slot that I cannot physically move onto, like some of the basement shelves.

The second bug involves the layering of clothing. Before leaving the shelter, my Lost Submissive character wanted to put on an emergency blanket, but the game wouldn’t let me because it said I was already wearing footwear. I tried taking off my character’s boots, which then let me put on the emergency blanket. But then she was not able to put the boots back on, and I received the same message as above…

I hope both these bugs will be fixed soon.

Thanks guys! :smiley:

you know you can just press [RIGHT ARROW] in the inventory menu and immediately be on the wielded item??


Yeah, that’s how I actually ended up selecting it. The bug still stands though, in the Windows Tiles builds…

Same version, on Ubuntu 14.04

I used a soldering iron to reinforce an improvised lockpick. My mechanics skill did not increase, which has been the skill that is trained previously when 'a’pplying a soldering iron. Neither was fabrication, tailoring, or electronics (as far as appropriate substitute skills may constitute).

Gutted! Just tried the latest experimental Windows Tiles build, and both the bugs I reported are still there. The build is 0.C-12632-g7e7570f.

With the missing inventory letters bug, this only seems to happen with certain items, perhaps ones with a changeable state. When I pick up the folded emergency blanket from the starting shelter locker, this does not have a letter, and it doesn’t get one once I have (a)ctivated the blanket to unfold it, either. Not sure if it’s related, but I have Auto Inventory Letters set to True. I did try setting it to False, but then of course, none of my inventory items have letters, and I’m not sure how you’re supposed to add letters to them, for quick selection.

The other bug is still there also, whereby I am not allowed to put on the unfolded emergency blanket because apparently, ‘You are already wearing footwear.’

Here’s really hoping one of the uber-brainy guys can fix these, as I have no clue how to program anything… :slight_smile:

‘You are already wearing footwear.’ is a message that I have received (same version a posted previously …ee227) when I have tried to put on a sheet, something that has not happened before.

Yeah, I think somebody accidentally screwed up the clothing/layering stuff during one of the many, recent changes… :slight_smile:

Okay, I’ve given it a few days now, and have just checked the latest experimental: 0.C-12806-ga9c1214.

However, I am still being told that I cannot wear the emergency blanket (or anything similar, probably) because I am already wearing footwear.

Once again, I hope this gets fixed soon, by somebody who knows what they are doing with the code…

The best way to get attention for your bug is to report them on Github. Make sure to provide the necessary steps to reliably reproduce the problem as well.

I noticed something to do with armor layering in a recent PR. I’ll check it out later, and if that hasn’t fixed it, then I’ll do as you suggest… :slight_smile:

I made a PR that addresses the second bug (https://github.com/CleverRaven/Cataclysm-DDA/pull/16173).


Hopefully that will fix the issue that I have been having with the Emergency Blanket, and which indigorain was having with the sheet… :slight_smile:

JazzGuru, it will, both cases.

Should be fixed now. Tested with 3 kinds of blankets.

Thanks guys, you rock!

It’s a good job I have a day off tomorrow… :slight_smile:

I am pleased to report that the 2nd bug is indeed fixed. The 1st however, still remains a problem, as of the latest experimental build on 15/4/2016…

That is not a bug to me. That is not preventing you from doing anything. You can still access items on a tile you cannot move onto by examining it (default key is [tt]e[/tt]). If you believe this to be a bug, I highly suggest you report it on the github issue tracker. Try to report your bugs effectively.

No offence, but I think you need to reread what I wrote, and please don’t tell me how to report bugs ‘effectively’, which I’ve been doing on this very forum for some years now… :wink:

My bad. Yeah, it’s a bug that has been reported on reddit as well.


Sorry if I was a little harsh in my response. I love this game, and want it to be as awesome as it can be… :wink:

Edit - Glad you linked that Reddit page. Now I can manually add letters to my inventory items… :smiley: