Vehicle removed by bug. How to solve this?

on loading in my vehicle is gone. CDDA guy wasnt waking up in an RV bed but was just standing on the road.

I created a bug report on github.

But what else can I do? Loosing everything this way feels really bad and frustrating. I mean just starting a new game does not do it. How do I know if this is not happen again, after starting over?

I had build a a custom RV on a HUMMVE to play the mission from the evac shelter console. The one where you have to reach the refugee center. All my gear was in the cargo spaces of this vehicle and all the loot from the first lab I ever was in.
I came 2 cities far on the road to the refugee center. I had fun in this game. I really had amazing fun. Only two cities travelled but this was such a fun adventure. Stuff like running away from two Skeletal juggernauts back to the RV. Just to kill them with the mounted .50 cal. in the last second before they entered the vehicle. But now with the veh. gone this game is totally screwed.

I restored to the previous Jenkins build as I updated before everything was gone. Wasn´t helping.

I created a new character on the same map. It spawned in the same starting location of missing vehicle guy.
I took a leftover vehicle of missing vehicle guy and went to the location, where the the other game was saved. But there was nothing. Only the leftovers of the fight in the previous game.

I had almost this exact same error happen to me, it seemed to be caused by a crash that happened while doing a “sleep and save” while in the vehicle. I assumed the save was corrupted after trying a few times to load with the same results (my mobile base had completely disappeared). I wasn’t able to fix this personally but good luck.

Well, personally I would never update if I have a save file I want to keep. There are too many instability issues. Find a version you want to keep and stick with it.

If the vehicle is gone and you don’t have a backup, it is gone for good. I recommend not using save during sleep and save manually instead. Also keep several backups.

As to not updating if you want to keep a save, I disagree with that. I am still using my save from 0.B with only minor issues along the whole way, mostly caused by mods. The key is to keep backups and test things with each update. Don’t move the save, copy it, that way you have a backup.

1 Like

I still back up my save as a .zip file every 24 hours despite never updating my game from ~7100.

One bad power outage while playing and your save could be corrupted - and this is from experience.

As fun as the game is, it is still not finished. What I really like is the progress made by the contributors. I contributed a little bit on github and noticing the progress which is made by the contributors is really motivating. Especially when you can notice how fast some reported issues get adressed.
But thoose issues with loosing everything…this feels really shitty.
What I have is the character with it´s skills. I think it is not cheating, giving me some things back via debug console.

As I build the vehicle from a Humvee I asume the issue is behind that. As I never reanamed the vehicle. After saving I went on playing and marked another Humvee for being remembered. Then I got killed on pulping a stack of zimbies in one tile and CTRL+ALT*DEL to kill the game before saving.
As vehicles are saved as marked in the map data, I asume that the issue is there.

Your vehicle on the map coordinates: level 0, 0’55, 0’110. Nice vehicle i have to say.

I relocated your vehicle next to your character. It is few steps away to the southeast. Here is the save:

A quick note: It is much easier to tell what is going on with full info at the start, such as saying you are savescumming. Vehicles, characters, and map don’t all save at the same time all the time, leading to events like that. The world is saved on death, but the character isn’t deleted until you exit the grave screen, so you get a half-save where your character reverts but nothing else does.

Glad you were able to get it back though.