Unknown "BLEED" thingy

im not sure whats going on here but so far im just going through secronom JSONs deleting every “BLEED” reference I can find, if this isnt right then hmu but if it actually gets my save working again then imma power onward

Yup. With blood overhaul merged, monster “bleed” flag is now obsolete. It’s not game bug, it’s just the mod wasn’t updated.

should I keep deleting or is the mod updated?

Well, you may try updating and if it is still throwing errors then it means the mod is not updated so you have to fix it yourself.

the latest secronom update is from 11 hours ago, would that work?
Im cautious to do that cause ive already spent an hour working this out and dont wanna have to redo half of this
ctrl+f does not seem to work in notepad most of the time for some reason so this is taking a while

eh im halfway through ill do it myself

…you mean…like… in… regular Notepad? opening (and replacing in) each file separately? :scream:
In Notepad++ it would be done in 3 “replace in files” actions.

Anyway, it seems Secronom is not a mainline mod so you better ask its author directly about bringing it in line with blood overhaul.

also I tried restoring a previous version before all this but as you can see that didnt work, how does that work? wouldnt it restore the game to a version where this isnt an issue?

theres a difference? and yes each and every file scrolling down and finding every “BLEED” reference I can find and removing them with two quick ctrl+backspace

imma download note++ now

can I get a quick dummy thicc tutorial on how to do this in the super appealing way you mentioned, preferably for someone who is viewing this software through virgin eyes

When you get np++:

  • open any json file in the mod folder
  • press Ctrl-H
  • switch to “find in files” tab
  • find what: "BLEED", , , "BLEED" and "BLEED" - 3 different replaces because it can be at the beginning, at the end or even be a single flag(not sure about the last one but who knows)
  • replace with: leave empty
  • filters: *.json
  • directory: should be something like moddir/monsters, or wherever monster data is stored in Secronom’s folder.
  • match case: yes.

Now 3 replaces via “replace in files” button, 1 for each version of “BLEED”, and it’s done.

1 Like

fingers crossed that I did it right

wound up getting the same error but with a couple of “^” or something and i thik thats because of my manual meddling so imma reinstall the mod and repeat the steps you gave

so secronom is fixed atleast :smiley:
Im guessing I need to update all manually installed mods?

quick list of my active mods in case that helps idk

ok I got it working
the erroneous “,” that was left over was because I didnt follow your steps in the order you specified, my bad, but luckily there was literally only one instance that required fixing manually and now ‘hopefully’ all is good
the game is running and I can get back to fixxing up my apc

thank you so much for your help and sorry for the bother <3