Help with flags and mods

#1

So, having little experience with coding, I am having trouble with adding the OVERSIZED flag to a modded item that is strapped to the torso (Aftershock’s Extradimensional Pack). Every time I add the flag into the mod’s json folder with Notepad++ and start the game, the pack is still unequippable with the insect torso mutation and its description does not change. What do I need to do to see a difference?

EDIT: It’s the dragon wings torso mutation, not insect.

#2
$ git grep OVERSIZE data/json/
data/json/flags.json:    "id": "OVERSIZE",
data/json/items/armor.json:    "flags": [ "OVERSIZE", "OUTER", "ALLOWS_NATURAL_ATTACKS" ]
data/json/items/armor.json:    "flags": [ "OVERSIZE", "WATER_FRIENDLY", "OUTER", "SPLINT" ]

You want the OVERSIZE flag, not the OVERSIZED flag.

1 Like
#3

So I saved it on the text editor where it says flags:

"flags": [ "OVERSIZE", "BELTED", "ONLY_ONE", "LEAK_DAM" ],

It still doesn’t fit on my dragon-winged character. Is it because the mods don’t play well together?

EDIT: It wasn’t insect wings, it was dragon wings. Despite me changing the materials to solely cotton (said wings prevent non-fabrics), it still won’t fit. In addition, the editor doesn’t seem to affect the flags at all; I tried adding the waterproof flag (can’t remember the specific name) and the description of the object doesn’t update.

#4

So, thought maybe wings interfere with belted equipment but that doesn’t look to be the case.

I don’t see any reason why changes would not appear in-game. This makes me think that you are not saving or that you might not have permission for the game folder and so it’s not actually overwriting the existing entry. If you’re on Windows this could possibly be the issue, try moving the game directory to your desktop. You could verify this by closing the file in notepad ++ and then reopening it from the directory. If it’s the original, then great, you know what your problem is. If it’s showing your changed version, well, then I don’t know.

Other than that, I’m genuinely at a loss. You should be able to at least see the changes you make on the in-game entry for that item. If that’s not it, I don’t know.

1 Like
#5

Before I sleep, the directory is the launcher right? Or is it the actual mod(s) folder? I’ve been opening and closing Notepad++, opening the mods folder from my Cataclysm file, and seeing the changed file there.

#6

The directory would be the main folder. If you installed it through the launcher it will probably be ‘cdda’. If you open the launcher, it will tell you what your directory is at the top, above version and build… That should be the location in which you’re editing the files.

Again, I’m not even sure if that’s the problem, just couldn’t think of anything more likely to be the answer.

1 Like
#7

I did what you said. The file is being edited, but nothing’s still happening. Well, I think we’re truly at a loss. Maybe I’ll go check in with the original mod maker. Anyway thanks for all the help.

#8

When I edit the JSON files in the same folder as the catacylsm-tiles.exe, the changes are immediately apparent the next time I reload. I’m not sure what you were doing for that to not happen. Good luck!