Trying to run Cataclysm DDA 0.D on OS X Snow Leopard

Hi Guys,

Been a lurker here since 2012, I really love this game and I have spent hundreds of hours playing on many systems. For the longest time I played on my 1999 IBM ThinkPad 600E with 0.6. Your game is really special, there is something indescribable about it. I feel like I could never get tired of it. There is so much to do! I usually spec my player as an archer and try to get up to the Metal Arrows, very little can get me at that point; unless I run out… I found many artifacts in weird places, each with their own unique effects to the player. I never beat the game as if you could, I just love exploring and finding cool things. It is a transcendent experience, unlike anything else that exists in the PC or Console spaces.

I bought a used iMac late 2006 and am trying to install Cata on it. I took the latest version and ran it 0.D and it came up with the following error:

dyld: Library not loaded: /usr/lib/libc++.1.dylib
Referenced from: /Applications/
Reason: image not found
Trace/BPT trap

Edit: I did try the unofficial 0.C build by Zacko, it wouldn’t open up the dmg. It said it was unrecognized.

1 Like

I haven’t been able to get anything after 0.C.5000-something to run on any Apple OS’es before 2018. You can search the forum for my username and “apple” and you should be able to find a discussion on the topic. I’ll try to remember to look for it when I get to a real computer (currently on my phone)

I looked at your posts and couldn’t get that specific build you listed, it cuts off between build 8888 and 8800. That’s as far back as it goes. Maybe someone with back-end knowledge can retrieve it, but even if they can get build 5000 it’s unlikely that it will run on OS X 10.6.8.

I would also like to mention that I tried compiling a build myself, but bailed out when I got invalid compiler option arguments. If I could get a version like 0.A and get it to compile I can stuff the updated binary into the Cataclysm “App” and it’ll probably work fine.

Thank you for the help. I appreciate it.

Earliest I can find is here, and just a Linux build.

I did some searching around and found a build with 0.8 that runs on my Mac. It also may be possible to build the latest version with it, as he posted the makefile.

I know it’s not the latest build or something, but it’s good enough, I’ll mark it as solved for now. If anyone finds a build of Danny that works for them, let me know. I’d love to try it.