Most Recent Mac Version Won't Open

Like…At all! I’m running on an OSX 10.6.8 Intel Macbook Pro and the “pre-10.7” version linked on the homepage won’t open. I open the .dmg and launch the file inside but it closes itself not a second afterwards.

Am I missing something? :S

Ok so I’ve hunted around a bit and come to find out that I need to do…Something or another in the terminal to compile or install the game? The old version was just click-and-run so I’m really new to this and all the tech jargon in the installation thread has me at a loss.

Ugh. Well first thought, what version of OS X do you have and which Mac build did you download? The first Mac build (labeled 10.7+) will only work on Lion or above. The 2nd one should work on older versions (Leopard, Snow Leipard).

Also, this may help:
http://smf.cataclysmdda.com/index.php?topic=4276.msg62162#msg62162

I am on OSX 10.6. I downloaded the pre-10.7 version first because it made the most sense to use. No dice. Tried the 10.7+ version on a whim and, of course, it didn’t work either.

I saw an earlier thread mentioning a very similar issue to mine, but with a slightly older build. However, I don’t believe anyone in the thread came up with a viable solution.

It’s really a bummer that Macs are such an under-supported platform in the gaming world, so if there’s anything I can do to help test builds and such, I’d be open to doing that in my free time. I don’t know a whole lot about coding outside of hella basic ActionScript, but the least I know when something works or doesn’t work.

To add, the error I seem to get in Terminal is “Image Not Found.” Sounds like I have a file missing or misnamed?

Well that’s bizarre. I’m assuming you started it from the console via something like:
$ open -a Cataclysm.app

?

Could you try looking inside Cataclysm.app/Contents/Resources and Cataclysm.app/Contents/MacOS for log files to see if there’s something interesting in them?

[quote=“pipehat, post:7, topic:4067”]Well that’s bizarre. I’m assuming you started it from the console via something like:
$ open -a Cataclysm.app

?

Could you try looking inside Cataclysm.app/Contents/Resources and Cataclysm.app/Contents/MacOS for log files to see if there’s something interesting in them?[/quote]

No, I didn’t open it in console. I just double-clicked the file.
I don’t know how to run things from the console or Terminal etc. I also have no idea what would constitute “something interesting” in any of the logs, so unless you can point me in the right direction I guess I’m kind of useless.

Like I said, the old version linked on the homepage pre-Kickstarter was just click-and-play so I’m very, very new to all this…Terminal and console command stuff. The last time I had to deal with any of this was back in my DOS days, so forgive me if I seem a little lost.

Maybe there’s another Mac user here on the forum who’s a little more tech-savvy who could help out?

Pipehat and me are about as mac savvy as you are gonna get. Sadly this dev team is remarkably lacking in mac people (and windows too for the most part), so things that are specific to anything other then linux tend to take a while.

Oh dear. I guess I’m just stuck with waiting then, huh? That’s cool, I understand. If there’s anything I can do to help though, let me know? I could probably scour the mentioned logs if I was told where they were and what I was looking for, exactly, ehehe.

Reno, would you be able to post & share your Cataclysm.app to google drive or dropbox? Then I could grab it and look at the logs myself. They’re inside the app bundle (which is actually just a fancy folder).

If you know how to zip things up you could do that too to make it faster to upload (right click on Cataclysm.app, select “Compress Cataclysm.app”) - that will create Cataclysm.app.zip which you can delete after uploading it somewhere.

It’s probably too big to post here on the forum though.

Also, another thing I’m checking, is your system 32 or 64 bit Reno?

For an example of how to check, if needed: http://support.apple.com/kb/ht3696

I just got bak from work so I’ve got some stuff to do but I’ll definitely get on that tonight!