The game doesn't recognize "<", and ">"

I can’t even start a new game.

Is this 0.6 Samedi or experimental build? If experimental, from which day?

1st: CAPSLOCK active by accident?
2nd: What language is your system language + keyboard?
3rd: You can also use PageUp and PageDown to move through the pages and for ingame you can remap the keys for stairs up/down.

I’ve just downloaded the latest build. My keyboard is Hungarian, it worked before.

I have czech keyboard and have to shift+alt to english setting every time I start Cata. It should solve your trouble too.

Tried that, didn’t work either.

Try changing the setting with mouse then… I’m helpless, sorry man.

I had the same problem with the “@” in the build from 2 days ago and from yesterday. Changed it in the keymap file to another key and it work but not the “@”. I have a french keyboard so i need to use “alt.car.+2” for “@”, maybe that is where the problem come from.

You can also use the page up and down for <>.

I see.
It seems I tried to simulated alt+number input so it blocked other alt key combinations.

The game does not recognize “Alt Gr + key” combinations of the Finnish keyboard, Which are @£$€{[]}|€~… This is really frustrating, please fix this ASAP…

Which alt is required for those input?
Perhaps right alt can be used to input alt+number while left alt is still functioning.

Maybe that’s it, AltGr isn’t recognized for some reason. Can someone take a look at that?

This exact thing was actually merged earlier today IIRC.

This exact thing was actually merged earlier today IIRC.[/quote]
Still doesn’t seem to work.

This exact thing was actually merged earlier today IIRC.[/quote]

I don’t think so.
https://github.com/CleverRaven/Cataclysm-DDA/pull/2031


Edit*
Never mind, kevin made it already.

NOW it’s definitely merged, can you check that it works now? Also, is having the left vs right Alt distinction acceptable, or does it need to be more configurable?

Still doesn’t seem to work. Also, I think the best is just to make it accept everything it would accept in notepad.

Did SDL version once support such input? Maybe it was broken from certain point.

Ah, I think I know the problem now.

Actually you needs right alt to input those characters, I thought Alt ang Gr are two different keys.

It used to work in the SDL version, for me “<” is Alt Gr+Í and “>” is Alt Gr+Y.