Keyboard issue with the angle brackets

Hi i’ve recently downloaded Cataclysm DDA after watching a couple of video about it , but when it comes to create my character i can go on after the stat tab , cataclysm wont recognise how my keyboard process the angle brackets ( < , > ) which annoys me alot ,because cataclysm is exactly the type of roguelike i was looking for ( i cant find how to make so that i dont need to shift+( whatever key is my bracket key ( , and . ) on my keyboard)) i was wondering if any of the dev or forum user here could enlighten me ?

  1. You’re unable to enter the “<” and “>” characters? Huh, that’s odd. What keyboard/layout/etc. are you using, which prevents them from being recognized?

  2. Are you able to compile the game from source? If so, open up newcharacter.cpp and edit the relevant occurrences of “<” and “>”. There might be other places where the game is confused by your keyboard, but at least that’ll be a start (and if you know how to fix one, you can try fixing more).

  3. If you can’t edit the source, I’ll see if I can make those configurable before the next official release.

Did you make sure you were holding shift?

1- No , i dont know how to compile the game from source :frowning:

2- Yes configurable keys for menu for the next release would be awesome :smiley:

3- Yes i was pretty much sure i was pressing shift :confused:

oh and i used English ( Canada, US, UK ) and French (Canada) layout to be sure , it just seems to me that the game doesnt recognise the shift key when used for brackets.

Im eager to finally play XD

If you still can’t do it, there’s key mapping tools, if you feel like rebinding capslock or something to a compatible key (if kb language is the issue).

Hmm… You’ve got a French-friendly keyboard, I take it? Uh… that… huh. Your “<” and “>” keys are on the same physical key, just with shift used to select which one? Yeah, that’s significantly different from the US keyboard, which maps “<” to shift-",", and “>” to shift-".".

no actually i have an english keyboard , the layout used by the canadian french is the same as us and UK my < and > keys are on coma and period keys

here is my keyboard even on my default layout i cant use thoses brackets :confused: i’ll give another look at the keyboard settings

EDIT : I FINALLY FOUND IT ! and i blame myself for being dumb as fuck XD it was the key between backspace and enter if you take a look on the picture.
I appreciate the support though, i’ll let you know if i run in any other problems

On the key that normally handles “” and “|”? Yeah, I see why you were having issues, then.

Nonetheless, I’ve logged it on the Github issue tracker - there are a lot of keymappings that would be good to make configurable, but this one seems particularly important.