Strange things happening with biotek u-dodge

In a mine with amigara horrors, starting from 2nd level down, I sometime auto-dodge… nothing. I tried using IR, NV or just regular light - there’s nothing visible. It, whatever it is, never hits me, I apparently dodge 100% of times. Dodge (judging by the message, it is uncanny dodge equivalent from biotek attunement) only procs on a move, if I stay still I can chill there for hours without anything happening.

But the weirdest thing is what’s happening with Alarm System CBM. I tried activating it, and in a single turn while I did not even move it procced 23 times and ate like 300kJ of energy, despite stating it only uses 1 joule per turn (it wasn’t UD procs - there were neither messages nor movement). Is it the same thing as UD’s proc cost which isn’t shown anywhere?
Also, what the hell did it detect? If you believe the logs, horrors themselves are 30km underground, and the alarm system can only detect things in, what, 15m radius? Or is it 15 feet? Anyway, only things that are very close to your location.

So… a bug? Or am I missing something (really not obvious)?

there should be other stuff in the caves leading UP to the horrors, but the horrors themselves dont show up until after you activate the event.

if you were outside I’d say check z levels… possibly something invisible?

i’d check myself in my game but i havent actually found a cave to delve so far, let alone a specific type.

or they filled the entire cave with invisible baddies that swipe at you but never hit you, which causes your character to ‘flinch’ because he’s scared of his surroundings… probably not though.

There was only single dark wyrm which i killed asap, and it was at the 1st level. After that, nothing I could detect. I don’t play with 3d vision so attacks from another z-level are… unlikely.
Actually, I don’t know if it is specifically AH mine or any other, I’ve only been to that one since attuning to biotek.

This affects your view… In my experience, it’s still possible that something from another Z-Level tries to attack you, even if you can’t see it.

I’m not familiar with the mines, but it’s possible that there are any type of worm… Since they are blind - as far as I know - it would make sense that they will not attack something that does not move.

If you don’t mind “cheating”, open the Debug Menu, go to [i]nfo… and choose Check [g]ame state press enter/space/escape twice and see what creatures get listed.

It’s also possible that your character is hallucinating and dodging stuff, so you might want to check the character screen too.
Also, I think there are other things that trigger the dodge message too, but I’d need to check which ones…

Amigara horrors iirc have the ability to do mental attacks, essentially able to paralyze you if you have less than 20 INT (I believe every time they spawn they generate a number between 1-20). So if you’re fighting them you’re probably auto-dodging them but they’re eating up your turns due to paralysis so maybe that’s why you’re getting your power + turns eaten.

Or, there’s a bug that spawns maybe a dummy enemy? That have horrible stats and don’t really do anything, but are related to the amigara horror “pre-enemy” I guess? Either that or maybe a new feature, I suppose. Definitely sounds like a bug to me.

Interesting. It never happened to me yet but such circumstances are quite rare so maybe I’ve been lucky.

Nope, not hallucinating.

If that wasn’t clear enough, let me rephrase: I am walking through the tunnel. Which is not on the lowest level where the horrors are (and they haven’t been spawned yet, anyway). Spontaneously I get UD activations - only when moving, never while standing still. I can see nothing in either normal light, IR vision, or using nightvision cbm.

Yes, I know. I have a way to deal with it which I won’t announce, lest it be “fixed”.

Well, the results of that are quite strange. There are 30 human snails and one vortex at level -7. They all seems to be near me, X-Y-wise, but the thing is, UD has been activating while I was wandering quite a long path through multiple levels so even if now it somehow emits something that goes through the floor and makes me dodge it, I very much doubt it was following my X-Y location and emitting that shit for up to 4 floors up.
Also, there are no stairs to level -7. Did I forget to mention that horrors room is at level -6? *checks the post* Yes.Yes I did.

An update: I’ve been driving on my scouter over the bridge and got the same UD proc out of the blue. And yes, it jerked me out of the seat, creating debug error about unboarding not-found vehicle in the process. And it’s reproducible, to boot. That’s it, I’m making an issue on github.

edit: alarm system doesn’t go mad on the bridge, though. Seems these are two different issues.

imagine dodging off a moving vehicle just because you ‘felt’ something was coming XD

might be some spooky eldritch horror lurking in the shadows

Imagine it actually happening instead of just imagining it :stuck_out_tongue:

If that’s what it is then it is the textbook case of horrible game design. There is no way to know what’s wrong, no clues whatsoever, no way to detect this eldritch thing, and even worse, no way to know what caused it so you can avoid falling into the same trap in the future.

I don’t think you understand the concept of “the fear of the unkown”

There is a distinction between the unknown and the unknowable. Former is fine, if I die to something unforeseen, that’s a lesson to learn and not to do that in the future.
Latter, though… if I die to something which I have no idea about (and cannot have by design), then it’s an irritating death which translates into nothing more than waste of my time, and serves no purpose*.

e: except maybe me deciding to stop playing the game. I’m quite sure the whole thing is just a bug, though.

true enough. die to a spike trap, well thats my fault i didnt see it. die to a spike trap that was invisible and randomly placed, well thats just a dick move.