So, how does the new archery work?

It seems that arrows no longer simply add damage as they used to - is it simply a multiplication now?

  • Shane
2 Likes

Yeah. That’s exactly how it works.

I thought so. Did they mean to utterly gut archery? If that’s a design decision, ok, but the net effect is that the damage has been drastically reduced and the ability to get any decent arrows has been moved to late game where archery was weak to begin with.

Oh, well. Maybe they’re planning to up the basic damage of bows and haven’t got around to it yet. If not, I might mod it in just to keep in the realism.

  • Shane

The massive nerf to archery was unintended. Far too much damage, AP, and range was attached to arrows and bolts, and I removed most of that without actually improving things on the other side. My plan is to somewhat increase existing bows/crossbows stats to bring them in line with an overall theme, then add more bows/crossbows to continue that theme.

The end result should be that there are a lot more options, and archery scales better with your strength, while crossbows can scale well into lategame with appropriate resources. Or you could go into pneumatics, which will also get some serious love.

6 Likes

So for now bows just broken?

A little bit. They’re weaker and shorter range than they were, but they’re still functional. I should have it more or less fixed within a week or so though.

i miss having 30 tiles of attacking range, and being able to craft arrows that can kill a zombie soldier, or skeleton.

You can just play an older version. 0.D isn’t very old and is quite stable.

Hey Darktoes, I know this is a WIP, but in my game bows appear to be bugged and I quite literally can’t seem to hit anything. I’m using a short bow with a dampener, level 3 Archery, with crude wooden arrows.

In a build from about a week ago, I was hitting targets predictably using the aim % stats. But now with the newer system, no matter how close I am, how much I steady my aim, or which key I press to fire, I cannot hit a single arrow. Not even close.

Maybe I’m doing something wrong though? I’m new to the community.

The crude wooden arrow is essentially an unfletched wooden stick. Try a makeshift wooden arrow instead. It at least has a flight.

I hear what you’re saying, but I don’t think that’s the issue.

See, I can steady my aim and close distance to the point where every aim/steadiness option adds up to 100% chance for a great/good/graze hit. So naturally I expect in these situations that no matter what aim mode I’m in or what fire key I press, I’m going to land some sort of hit.

But that’s not the result I’m getting - I have yet to land a shot in the newest build.

It’s quite possible you’ve found a legitimate bug, or you might just be suffering from a well known one. First, can you provide some screenshots and/or a copy of your save? and/or confirm that your shortbow is undamaged and you’re not trying to shoot at something above/below you?

Can you tell me what the arrow is actually doing? Does it fly off in a random direction? Plonk onto the ground in front of you?

That’s kind of what I’m saying. You’re using an arrow with a dispersion of 250 which is added to the dispersion of the bow (IIRC) meaning you’re using a grossly inaccurate form of firing.

I see darktoes typing so I’ll leave it to him since he’s the actual expert on this.

2 Likes

Did a little test of my own, and I’m definitely noticing that arrows from the shortbow don’t reach nearly their expected range. Not entirely sure what’s going on, but I’ll ask around.

3 Likes

Sure, here’s a copy of my save attached (I think? It’s just my world folder found in Saves.)

The bow is missing 1 tick of health (currently at | \ ). Not shooting at anything weird, just zombies right in front of me, same z-level. The arrows don’t fly in random directions - always in a cone in front of me, but they’ll often plunk down right in front of me or disappear, or land somewhere around the target - but never hitting, and I’ve tested ~100 shots at basically all levels of steadiness/aim/distance.

This bow worked predictably at its current health level in the previous build from ~ 1 week ago.

*Edit when I saw your newest comment - yes, I also noticed that the range had been noticeably reduced, but figured that was intentional. shrug

There seems to be something odd going on with the shortbows low damage rating. I wasn’t able to get arrows to get more than a few tiles, despite having a listed max range of 12. If you repair your bow it might fix itself, since damaged ranged weapons lose damage value and that seems to be the cause of whatever is going on.

EDIT: When I play, the shortbow has a listed range of 12 tiles. Yet the game has it listed as a range of 4 in the code. What does the game list for your range when you go to fire the shortbow?

Alright, I’ll try making a new one and report back. FYI I just examined my current bow - it’s reporting a max range of 6 and a damage rating of -2. :rofl:

So… -2… *70%… carry the 1… yep, seems like a healing arrow. Lol

3 Likes

The damage rating of -2 is definitely the problem. Projectiles with 0 damage (No idea what negative damage projectiles do, but it can’t be good) don’t fire at all. That said, something funky is going on with ranges.

For what it’s worth, the arrows are always consumed btw.

Yeah I worked out. See, there’s this archaic flag called STR_DRAW which is attached to most bows. Basically, it checks your strength against the minimum strength for the bow, and gives you bonus range proportional to how far you overshoot the minimum strength requirement. HOWEVER it does not work properly, and only increases the range you can aim at without increasing the range the projectile can travel. A shortbow has a range of 4, having strength above the minimum of 4 (I’ll assume your character has 10 or so) makes the game think you can shoot further than you actually can.

In your case, your bow is too broken to actually fire. Repair it and shoot at things within 4 tiles and it should work perfectly. I’m aware 4 tiles is pathetic, and will probably fix it soonish.