Hey guys, i know there already many threads on this, but I just cant get my resolution to work properly. 1920 x 1080 monitor. The tile size is quite small, so i had a look at the fontdata tweaking that many people have recommended. I have looked in both config/fonts.json and the data/fontdata.json, and i’m not sure what to change.


“fontblending”: false,
“fontwidth”: 8,
“fontheight”: 16,
“fontsize”: 16,
“typeface”: “Terminus”,
“map_fontwidth”: 8,
“map_fontheight”: 16,
“map_fontsize”: 16,
“map_typeface”: “Terminus”


“fontblending” : false,
“fontwidth” : 8,
“fontheight” : 16,
“fontsize” : 16,
“typeface” : “Terminus”,
“map_fontwidth” : 8,
“map_fontheight” : 16,
“map_fontsize” : 16,
“map_typeface” : “Terminus”,
“overmap_fontwidth” : 8,
“overmap_fontheight” : 16,
“overmap_fontsize” : 16,
“overmap_typeface” : “Terminus”

People have suggested to change the tile sizes, but with some playing around, all I manage to do is make my resolution worse. Any help would be much appreciated. Also, playing on the newest stable release.

No body knows what i can do??

Could you rephrase what you’re asking? I don’t quite understand what you’re trying to change/fix.

EDIT: If you’re just trying to increase the size of the game window, it’s Terminal Length and Terminal Width settings under options -> Graphics.

I mean that playing fullscreen 1920x1080 has the tiles way too small, how can I enlarge the tile sizes whilst keeping the resolution?

Tiles… or font?

Try increasing the all the numeric values in fonts.json. Keep the ratios of all numbers constant.

Though I also recommend getting a square font. It really helps.

Don’t be afraid to experiment with those values. You can always restore the default config by deleting the files.

If the font size is ok but the tiles are small just press z or shift+z to zoom in/out.